HDU4122 单调队列优化DP

传送门:点击打开链接

Alice's mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3145    Accepted Submission(s): 799


Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest.

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
 


Input
The input contains no more than 10 test cases.
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens.
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers.
All the orders are sorted by the time in increasing order.
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the i th line( i starts from 1) contains a integer indicating the cost to make a mooncake during the i th hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1 st hour, Jan 1st 2000 1 o'clock belongs to the 2 nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.
 


Output
You should output one line for each test case: the minimum cost.
 


Sample Input
  
  
1 10 Jan 1 2000 9 10 5 2 20 20 20 10 10 8 7 9 5 10 0 0
 


Sample Output
  
  
70
Hint
“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o'clock , there's a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.
 


Source
题意:
Alice开了一家月饼店。有n张订单,做月饼不需要时间。月饼的工作m小时,给出每小时原料的成本,月饼的保质期和每小时每个月饼的存储价格。求完成所有订单所需的最小费用。
思路;订单直接相互没有影响,那么让单张订单花费最小,那么就是全局最小。假设某张订单在第i小时,那么这张订单的花费DP[i]=min(DP[j]+(i-j)*S) (0<=i-j<=T);
由于T很大,所以这个DP的转移需要优化。可以让每个月饼的制作成本最小即可。详细见代码。
#include<cstdio>
#include<cstring>
#include<queue>
#define LL __int64
using namespace std;
char mon[13][5]={"AMD","Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" , "Dec" };
LL days[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
bool leap(LL y)
{
    if(y%400==0||(y%100!=0&&y%4==0)) return 1;
    return 0;
}
struct List
{
    LL time,num;
};
struct node
{
    LL pri,time;
};
List t[100005];
int main()
{
    LL n,m;
    while(scanf("%I64d %I64d",&n,&m),n||m)
    {
        for(LL i=1;i<=n;i++)
        {
            char s[10];
            LL year,mouth,day,hour,num;
            scanf("%s %I64d %I64d %I64d %I64d",s,&day,&year,&hour,&num);
            for(int j=1;j<=12;j++)
            if(strcmp(mon[j],s)==0)
            {
                mouth=j;
                break;
            }
            LL tmp=0;
            for(LL j=2000;j<year;j++) if(leap(j)) tmp+=366;
            else tmp+=365;
            for(LL j=1;j<mouth;j++)
            {
                tmp+=days[j];
                if(leap(year)&&j==2) tmp++;
            }
            tmp+=day-1;
            tmp=tmp*24+hour;
            t[i]=(List){tmp,num};
        }
        t[n+1]=(List){-1,0};
        LL S,T;
        scanf("%I64d %I64d",&T,&S);
        deque<node>q;
        int tmp=1;
        LL ans=0;
        for(LL i=0;i<m;i++)
        {
            LL p;
            scanf("%I64d",&p);
            while(!q.empty()&&q.back().pri+(i-q.back().time)*S>=p) q.pop_back();
            q.push_back((node){p,i});
            while(t[tmp].time==i)
            {
                while(i-q.front().time>T) q.pop_front();
                ans+=(q.front().pri+(i-q.front().time)*S)*t[tmp].num;
                tmp++;
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值