HDU - 4122——Alice's mooncake shop (单调队列之制作月饼)

The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest.

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
Input The input contains no more than 10 test cases.
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens.
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers.
All the orders are sorted by the time in increasing order.
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the i th line( i starts from 1) contains a integer indicating the cost to make a mooncake during the i th hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1 st hour, Jan 1st 2000 1 o'clock belongs to the 2 nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0. Output You should output one line for each test case: the minimum cost.
Sample Input
1 10
Jan 1 2000 9 10
5 2
20 
20 
20 
10 
10
8
7 
9 
5 
10
0 0
Sample Output
 

70

题意:第一行n,m;随后n行代表在某年某月某日有人预定x个月饼,随后一行t,s,月饼最长保存时间和保存费用。随后m行,在    0——m的时间制作月饼需要的费用。求完成订单需要的最小成本。
思路:把年月日转化为小时,然后开对应数组存下定做的月饼数。用优先队列处理0——m时间制作月饼需要的费用,找出在s的保存时间内成本最小的制作时间。
坑点:同一时间可能有多个预定。
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<map>
#define M 100010
using namespace std;
char month[10];
int years,daily,number,hour,s,t;
int order[M];
int f[15]={0,31,28,31,30,31,30,31,31,30,31,30,31};
struct node
{
    int x,i;
}q[M];
map<string,int>yy;
int run(int x)
{
    return (x%4==0&&x%100!=0)||x%400==0;
}
int sum_hour()//时间转换
{
    int ans=0,yue;
    ans+=hour;
    ans+=(daily-1)*24;
    yue=yy[month];
    for(int i=1;i<yue;i++)
    {
        if(i==2&&run(years))
            ans+=29*24;
        else
            ans+=f[i]*24;
    }
    for(int i=2000;i<years;i++)
    {
        if(run(i))
            ans+=366*24;
        else
            ans+=365*24;
    }
    return ans;
}
init()
{
    yy["Jan"]=1,yy["Feb"]=2,yy["Mar"]=3,yy["Apr"]=4;
    yy["May"]=5,yy["Jun"]=6,yy["Jul"]=7,yy["Aug"]=8;
    yy["Sep"]=9,yy["Oct"]=10,yy["Nov"]=11,yy["Dec"]=12;
}
int main()
{
    int n,m,x;
    init();
    while(~scanf("%d%d",&n,&m),n||m)
    {
        memset(order,0,sizeof(order));
        for(int i=0;i<n;i++)
        {
            scanf("%s%d%d%d%d",month,&daily,&years,&hour,&number);
            order[sum_hour()]+=number;
        }
        scanf("%d%d",&t,&s);
        int head=0,tail=0;
        long long ans=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d",&x);
            while(head<tail&&q[tail-1].x+(i-q[tail-1].i)*s>=x)tail--;
            q[tail].i=i,q[tail++].x=x;
            while(q[tail-1].i-q[head].i>t)head++;//控制时间在保质期内
            if(order[i])
                ans+=(q[head].x+(i-q[head].i)*s)*order[i];
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值