(hdu6075) 2017杭电多校联赛第四场-Questionnaire 思维题

Questionnaire

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0
Special Judge


Problem Description
In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.



Picture from Wikimedia Commons


Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer  ai  to represent his opinion. When finished, the leader will choose a pair of positive interges  m(m>1)  and  k(0k<m) , and regard those people whose number is exactly  k  modulo  m  as ''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training.

Please help the team leader to find such pair of  m  and  k .
 

Input
The first line of the input contains an integer  T(1T15) , denoting the number of test cases.

In each test case, there is an integer  n(3n100000)  in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are  n  distinct integers  a1,a2,...,an(1ai109) , denoting the number that each person chosen.
 

Output
For each test case, print a single line containing two integers  m  and  k , if there are multiple solutions, print any of them.
 

Sample Input
  
  
1 6 23 3 18 8 13 9
 

Sample Output
  
  
5 3
题目大意:老师想要给学生进行acm训练,但是有很多学生不想训练,所以教练让每个学生选择一个正整数,然
后需要我们找到一组m和k,使得 学生选择的数字整除m之后等于k的数尽可能的多,这样才可以让学生继续参加
训练。
解题思路:因为题目要求的m和k不是唯一确定的,只需要我们找到能满足题意的就可以了,这里我选择的是奇数
和偶数,因为一个正整数要么是 奇数要么就是偶数,所以我们选择的m是2,所以k值我们需要确定是0还是1就可
以了,我们只需要处理每一个数,判断是奇数多还是偶数多,如果 奇数多k值就为1,否则k就是0.
ac代码:
#include <cstdio>
int main()
{
	int T,n,a,sum1,sum2;
	scanf("%d", &T);
	while(T--)
	{
		sum1=sum2=0;
		scanf("%d", &n);
		while(n--)
		{
			scanf("%d",&a);
			if(a&1) sum2++;
			else sum1++;
			}
		 if(sum1>=sum2)
				printf("%d %d\n",2,0);
		 else 	printf("%d %d\n",2,1);
		}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值