hdu 5325 Crazy Bobo 乱搞+搜索

Crazy Bobo

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 218    Accepted Submission(s): 60


Problem Description
Bobo has a tree,whose vertices are conveniently labeled by 1,2,...,n.Each node has a weight  wi . All the weights are distrinct.
A set with m nodes  v1,v2,...,vm  is a Bobo Set if:
- The subgraph of his tree induced by this set is connected.
- After we sort these nodes in set by their weights in ascending order,we get  u1,u2,...,um ,(that is, wui<wui+1  for i from 1 to m-1).For any node  x  in the path from  ui  to  ui+1 (excluding  ui  and  ui+1 ),should satisfy  wx<wui .
Your task is to find the maximum size of Bobo Set in a given tree.
 

Input
The input consists of several tests. For each tests:
The first line contains a integer n ( 1n500000 ). Then following a line contains n integers  w1,w2,...,wn  ( 1wi109 ,all the  wi  is distrinct).Each of the following n-1 lines contain 2 integers  ai  and  bi ,denoting an edge between vertices  ai  and  bi  ( 1ai,bin ).
The sum of n is not bigger than 800000.
 

Output
For each test output one line contains a integer,denoting the maximum size of Bobo Set.
 

Sample Input
  
  
7 3 30 350 100 200 300 400 1 2 2 3 3 4 4 5 5 6 6 7
 

Sample Output
  
  
5
 


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5325

解题思路:反正我是智商余额不足。。。


AC代码:顺着题解思路DFS了一下= =

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <stack>
#include <limits.h>
using namespace std;
typedef long long LL;
#define y1 y234
#define MAXN 500010 // 1e6
int n;
int a[MAXN];
vector<int> edge[MAXN];
int ans[MAXN];
void DFS(int u) {
    ans[u] = 1;
    int len = edge[u].size();
    for(int i = 0; i < len; i++) {
        int v = edge[u][i];
        if(!ans[v]) DFS(v);
        ans[u] += ans[v];
    }
}
int main() {
    while(~scanf("%d", &n)) {
        memset(ans, 0, sizeof ans);
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
            edge[i].clear();
        }
        int u, v;
        for(int i = 1; i < n; i++) {
            scanf("%d%d", &u, &v);
            if(a[u] < a[v]) edge[u].push_back(v);
            else if(a[v] < a[u]) edge[v].push_back(u);
        }
        for(int i = 1; i <= n; i++) {
            if(ans[i]) continue;
            DFS(i);
        }
        int maxn = -1;
        for(int i = 1; i <= n; i++) {
            maxn = max(ans[i], maxn);
        }
        printf("%d\n", maxn);
    }
    return 0;
}


评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值