关闭

解决INSTALL_FAILED_MISSING_SHARED_LIBRARY方法汇总主帖

436人阅读 评论(0) 收藏 举报
分类:
网上搜了很多,大多都无外乎以下几种解决方法。3楼,4楼,是对第三种方法的改进,6楼是另外一种解决办法。
1.由于该问题大多出现在google map相关的应用上。
    所以大多的回答者说 在新建工程时 选择target 为Google apis,针对google map,该方法是可以解决的。
    该链接的方法可以解决。
http://stackoverflow.com/questions/1113088/install-failed-missing-shared-library-error-in-android
    但是对于其他第三方jar包是不行的。
2.还有一部分回答者说将google map的相关jar包push到手机上。
    我只想说,你发布的应用,难道让用户自己去push相关jar包吗?该方法只适合自己做测试。应该选择用第一种解决方法。

3。对于你的app引用第三方其它的jar包时,eclipse也报这样的错误,你是不是很崩溃,尤其是搞了多半天,也没有头绪。擦,让我给遇上了。
    既然app引用第三方jar包,报错。那我就猜想,我以前其它的app引用jar包也没报错啊,于是我就把以前的app导入到eclipse,一看,擦,果然有所不同。
    在eclipse中,以前的app下的jar包是 在
Android Dependencies”目录下,
                          而现在的app的jar包是在 “Referenced Libraries”目录下。
   后来我就在app的目录下新建了 文件夹“libs”,然后将jar包copy进去。到eclipse中选择工程F5,刷新一下,ok,就会出现
"Android Dependencies" 目录。 
   然后运行app,OK,可以了。
   
同事的eclipse上运行没问题,而我的就有问题,还以为是人品问题。
   解决后,我就去看了同事的eclipse版本,他的是indigo-j2ee,而我的是indigo-java。
   擦,问题的根源找到了,原来是eclipse版本的问题。
   java版本对与jar包只是引用,在本地编译,保证app代码不会报错,但是对于app的打包,安装就不行了,它不会把jar包一起打包。
   而j2ee版的就不会出现该问题。

给自己留个备份,同时也给那些在网上搜很多资料都解决不了的developer。

而且在logcat中也会出现这样的错误  Package com.**.demo requires unavailable shared library com.**.; failing!

这就是因为eclipse-java版不会把jar包打到apk包中,所以安装的时候就报这样的错误。

修改后,删除清单文件中的<uses-library android:name="com.**.map"/>。

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:222883次
    • 积分:1617
    • 等级:
    • 排名:千里之外
    • 原创:18篇
    • 转载:65篇
    • 译文:0篇
    • 评论:4条