HDU 5616 Jam's balance

Problem Description
Jim has a balance and N weights.  (1N20)
The balance can only tell whether things on different side are the same weight.
Weights can be put on left side or right side arbitrarily.
Please tell whether the balance can measure an object of weight M.
 

Input
The first line is a integer  T(1T5) , means T test cases.
For each test case :
The first line is  N , means the number of weights.
The second line are  N  number, i'th number  wi(1wi100)  means the i'th weight's weight is  wi .
The third line is a number  M M  is the weight of the object being measured.
 

Output
You should output the "YES"or"NO".
 

Sample Input
  
  
1 2 1 4 3 2 4 5
 

Sample Output
  
  
NO YES YES
Hint
For the Case 1:Put the 4 weight alone For the Case 2:Put the 4 weight and 1 weight on both side


题意:有一个没有游标的天平,和n个秤砣,m个询问, 每次一个k,
问可否秤出k这个重量。 秤砣可以放两边。

dp[n][sum]存储可达与不可达....
dp[i][j] 表示放前i个秤砣能否称出j重量 
因为相减可能为负 所以把全部值加上sum 避免出现负数
因此初始为 dp[0][sum] = 1 


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define ULL unsigned long long
#define inf 0x3f3f3f3f
#define INF 1e18
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
typedef pair<int, int> P;
const int maxn = 1e5 + 5;
const int mod = 1e8;

int dp[25][maxn];
int a[25];
int main(void)
{
//	freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
    int T, i, j, n, m, sum, t;
    cin >> T;
    while (T--)
    {
        sum = 0;
        cin >> n;
        for (i = 1; i <= n; i++){
            cin >> a[i];
            sum += a[i];
        }
        memset(dp, 0, sizeof(dp));
        dp[0][sum] = 1;
        for (i = 1; i <= n; i++){
            for (j = 1; j <= 2*sum; j++){
                if (dp[i-1][j]){
                    dp[i][j] = 1;
                    dp[i][j - a[i]] = 1;
                    dp[i][j + a[i]] = 1;
                }
            }
        }
        cin >> m;
        while (m--){
            cin >> t;
            if (t > sum) puts("NO");
            else if (dp[n][t + sum])
                puts("YES");
            else puts("NO");
        }
    }

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值