华中农大网络同步赛

Problem J: Arithmetic Sequence

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 1804   Solved: 308
[ Submit][ Status][ Web Board]

Description

    Giving a number sequence A with length n, you should choosing m numbers from A(ignore the order) which can form an arithmetic sequence and make m as large as possible.

Input

   There are multiple test cases. In each test case, the first line contains a positive integer n. The second line contains n integers separated by spaces, indicating the number sequence A. All the integers are positive and not more than 2000. The input will end by EOF.

Output

   For each test case, output the maximum  as the answer in one line.

Sample Input

5
1 3 5 7 10
8
4 2 7 11 3 1 9 5

Sample Output

4
6

HINT



   In the first test case, you should choose 1,3,5,7 to form the arithmetic sequence and its length is 4.


   In the second test case, you should choose 1,3,5,7,9,11 and the length is 6.

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<queue>
#include<set>
using namespace std;
const int N=5e4+9;
#define pb push_back
int a[100001];
 int q[100001];
 int haha[100001];
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
          memset(q,0,sizeof(q));
         memset(haha,0,sizeof(haha));
    int maxa=-10;
    int maxaa=-10;
    for(int i=1;i<=n;i++)
    {
        cin>>a[i];
        haha[a[i]]++;
    }
    sort(a+1,a+1+n);
    for(int i=1;i<=n;i++)
    {
        if(haha[a[i]]>maxaa)
        {
            maxaa=haha[a[i]];
        }
    }
     for(int i=1;i<=a[n]-a[1];i++)
    {
      
            int l=1,r=1;
            while(l<=n&&r<=n)
            {
            if(a[r]-a[l]==i)
            {
                q[i]++;
                l=r;
                r++;
            }
            else
            {
               
                if(a[r]-a[l]>i)
                {
                    if(maxa<q[i])
                    {
                        maxa=q[i];
                    }
                   
                    l++;
                    r--;
                    q[i]=0;
                }
                 r++;
                
            }
            
            }
        
                    if(maxa<q[i])
                    {
                        maxa=q[i];
                    }
    }
   if(maxa+1>maxaa)
    cout<<maxa+1<<endl;
    else
    cout<<maxaa<<endl;
    
    }
    return 0;
}

/*7

1 2 3 4 6 8 10

*/

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<set>
#include<vector>
#include<string.h>
#include<map>
const int N=1e4+5;
using namespace std;
int s[3000];
int c[3000];
int d[3000];
int e[3000];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(c,0,sizeof(c));
        memset(d,0,sizeof(d));
        int a;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            c[a]++;
        }
        int l=0;
        int m=0;
        for(int i=0;i<=2000;i++)
        {
            if(c[i]>m) m=c[i];
            if(c[i]) s[l++]=i;
        }
        for(int i=0;i<l;i++)
        {
            for(int j=i+1;j<l;j++)
            {
                int x=s[j]-s[i];
                if(x<0)d[-x]=1;
                else d[x]=1;
            }
        }
        l=0;
        for(int i=0;i<=2000;i++)
        {
            if(d[i]) e[l++]=i;
        }
        for(int j=0;j<l;j++)
        {
            for(int i=1;i<=2000;i++)
            {
                int cnt=1;
                int k=i;
                if(c[k])
                {
                    while(c[k+e[j]]&&k+e[j]<2000)
                    {
                        cnt++;
                        k=k+e[j];
                    }
                    if(cnt>m)
                    {
                        m=cnt;
                    }
                }


            }
        }
        cout<<m<<endl;
    }
    return 0;
}

一个个枚举最好,我是想不出来吗

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值