hdu5778

abs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 808    Accepted Submission(s): 293


Problem Description
Given a number x, ask positive integer  y2 , that satisfy the following conditions:
1. The absolute value of y - x is minimal
2. To prime factors decomposition of Y, every element factor appears two times exactly.
 

Input
The first line of input is an integer T (  1T50 )
For each test case,the single line contains, an integer x (  1x1018 )
 

Output #include<cstdio>
For each testcase print the absolute value of y - x
 

Sample Input
   
   
5 1112 4290 8716 9957 9095
 

Sample Output
   
   
23 65 67 244 70

   

Source
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
const long long INF=0x7fffffffffffffll;
using namespace std;
long long ans;
long long n;
bool work(long long x)
{
    if(x<2)
    {
        return false;
    }
    long long t=x;
    for(long long i=2;i*i<=x;i++)
    {
        if(x%i==0)
        {
            if(x%(i*i)==0)
            {
                return false;
            }
            x/=i;
        }
    }
   // cout<<abs(t*t-n)<<endl;
    ans=min(ans,abs(t*t-n));
    return true;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        scanf("%lld",&n);
        long long x=(long long)(sqrt(n)+0.5);
        cout<<sqrt(n)<<endl;
        cout<<x<<endl;
        long long oo=(long long)(sqrt(n));
        cout<<oo<<endl;
        int flag=0;
        ans=INF;
        for(int i=0;;i++)
        {
            if(work(x+i))
            flag=1;
            if(work(x-i))
            {
                flag=1;
            }
            if(flag==1)
            break;
        }
       // printf("%lld\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值