HDU 1061 JAVA

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

package hlh;

import java.util.Scanner;

public class p1061 {

    // 用来找规律: 1~10:1 4 7 6 5 6 3 6 9 0
    // 用来找规律: 11~20:1 6 3 6 5 6 7 4 9 0 
    // 用来找规律: 21~30:1 4 7 6 5 6 3 6 9 0  
    // 用来找规律: 31~40:1 6 3 6 5 6 7 4 9 0  
    public static void main(String[] args) {
        /*  for(int x=111;x<=120;x++){
                int temp = x%10;
                for(int i=1;i<x;i++){
                    temp = (temp*x%10)%10;
                }
                System.out.print(temp+" ");
            }*/
        Scanner sc = new Scanner(System.in);
        int t=sc.nextInt();
        while(t-->0){
            int a [] = {1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
            int x =sc.nextInt();
            x = x%20;
            if(x%10==0){
                System.out.println(0);
                continue;
            }
            System.out.println(a[x-1]);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值