Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66486 Accepted Submission(s): 24925
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include<bits/stdc++.h>
#define LL long long
using namespace std;
int Pow(LL a,LL b,LL c)
{
LL ans=1;
a=a%c;
while(b>0)
{
if(b&1) ans=(ans*a)%c;
b/=2;
a=(a*a)%c;
}
return ans;
}
int main()
{
int t; cin>>t;
while(t--)
{
LL n;
scanf("%lld",&n);
cout<<Pow(n,n,10)<<endl;
}
return 0;
}