HDU 1164 JAVA

Eddy’s research I

Problem Description

Eddy’s interest is very extensive, recently he is interested in prime
number. Eddy discover the all number owned can be divided into the
multiply of prime number, but he can’t write program, so Eddy has to
ask intelligent you to help him, he asks you to write a program which
can do the number to divided into the multiply of prime number factor
.

Input

The input will contain a number 1 < x<= 65535 per line representing
the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer
to the previous question.

Sample Input

11

9412

Sample Output

11

2*2*13*181

题目大意:任意一个数,都可以分解成质数因子相乘的形式。只要把这些因子相乘的形式输出

package hlh;

import java.util.Scanner;

public class p1164 {

    /**
     * @author 胡龙华
     */
    public static void main(String[] args) {
        // 质数:只能被1和他本身整除的数。
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            boolean isFirst = true;
            int num =sc.nextInt();
            aa(isFirst, num);
            System.out.println();
        }
    }

    private static void aa(boolean isFirst, int num) {
        for(int i=2;i<=num;i++){
            if(!isPrime(i)){ // 不是质数 直接跳过
                continue;
            }
            if(num%i==0){ // 说明i 是她的质数 因子
                if(!isFirst){ // 除了第一次之外每次都要 输出一个*好
                    System.out.print("*");
                }
                isFirst = false;
                System.out.print(i);
                // 如果没有下面这部分,那么 8 的 话只会 输出2 ,所以的因子只会输出一次
                //  重新调用的话  就会  输出 2*2*2 
                aa(false,num/i);
                break;
            }
        }
    }
    /**
     * 
     * @param  任意整数
     * @return 如果是质数 返回true  不是 返回false
     */
    private static boolean isPrime(int num) {
        if(num==2)
            return true;
        for(int i=2;i<=Math.sqrt(num);i++){
            if(num%i==0){
                return  false;
            }
        }
        return true;
    }

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值