A Simple Problem with Integers(POJ-3468)(线段树)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 71540 Accepted: 22049
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

该题的关键是要高效的实现对一个区间的每个数都加上一个数,所以增加了一个数组data表示这一次加的那个数,datb表示去掉这个数的区间和。然后在sum函数里更新这两个值。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int DAT_SIZE = (1<<18)-1 ;
const int MAX_N = 100005;
const int MAX_Q = 100005;
int n,q,a,b,c;
char s[10];
ll data[DAT_SIZE],datb[DAT_SIZE];
void add(int a,int b,int x,int k,int l,int r){
    if(a<=l&&r<=b) data[k] += x;
    else if(l<b&&a<r) {
        datb[k] += (min(b,r)-max(a,l))*x;
        add(a,b,x,k*2+1,l,(l+r)/2);
        add(a,b,x,k*2+2,(l+r)/2,r);
    }
}
ll sum(int a,int b,int k,int l,int r){
    if(b<=l||r<=a) return 0;
    else if(a<=l&&r<=b) return data[k] * (r-l) + datb[k];
    else {
        ll res = (min(b,r) - max(a,l)) * data[k];
        res += sum(a,b,k*2+1,l,(l+r)/2);
        res += sum(a,b,k*2+2,(l+r)/2,r);
        return res;
    }
}
int main(){
    scanf("%d%d",&n,&q);
    for(int i=0;i<n;i++) {
        scanf("%d",&a);
        add(i,i+1,a,0,0,n);
    }
    while(q--) {
        scanf("%s",s);
        if(s[0]=='C') {
            scanf("%d%d%d",&a,&b,&c);
            add(a-1,b,c,0,0,n);
        } else {
            scanf("%d%d",&a,&b);
            printf("%lld\n",sum(a-1,b,0,0,n));
        }
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值