poj 1419 Graph Coloring(无向图的最大独立集)

Graph Coloring
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3645 Accepted: 1612 Special Judge

Description

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.



Figure 1: An optimal graph with three black nodes

Input

The graph is given as a set of nodes denoted by numbers 1...n, n <= 100, and a set of undirected edges denoted by pairs of node numbers (n1, n2), n1 != n2. The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

Output

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5
 
题意:给出一个无向图,要求给图中的点着色,可以用白色或黑色,规定不能有两个黑色的点相邻,问最多可以给多少个点着黑色。
思路:求无向图的最大独立集。最大独立集=补图的最大团。
 
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <map>
#include <cstdlib>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define ll long long
#define eps 1e-6
using namespace std;

const int maxn=105;
bool G[maxn][maxn];
bool vis[maxn],color[maxn];
int n,m,cnt,bestn;
void dfs(int u)
{
    if(u>n)
    {
        if(cnt>bestn)
        {
            bestn=cnt;
            for(int i=1;i<=n;i++) color[i]=vis[i];
        }
        return;
    }
    bool ok=true;
    for(int i=1;i<u;i++)
    if(vis[i]&&!G[i][u])
    {
        ok=false;
        break;
    }
    if(ok)
    {
        vis[u]=true;
        cnt++;
        dfs(u+1);
        vis[u]=false;
        cnt--;
    }
    if(cnt+n-u>bestn) dfs(u+1);
}
int main()
{
    int t,a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        for(int j=i;j<=n;j++)
        G[i][j]=G[j][i]=true;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            G[a][b]=G[b][a]=false;
        }
        cnt=bestn=0;
        memset(vis,false,sizeof(vis));
        dfs(1);
        printf("%d\n",bestn);
        for(int i=1;i<=n;i++)
        if(color[i]) printf("%d ",i);
        puts("");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值