[PAT甲级]1017. Queueing at Bank (25)(银行办理业务平均等待时间)

1017. Queueing at Bank (25)

原题链接
相似题目 1014. Waiting in Line (30)
Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

题目大意:

  • 银行排队办理业务,有N个人,K个窗口
  • 给出N个人的到达银行时间,个人办理业务所需要的时间,求平均等待时间
  • 银行窗口08:00开始办理业务,下午17:00之后到达的人不接受办理,不算有效的人
  • 每个窗口前只能有一个人办理业务,其他的人均在黄线外等待,有窗口最先空闲(前一个人办理业务结束),等待的顾客就可以按照到达时间的先后顺序去办理

思路:

  • 定义结构体记录顾客到达时间come,办理业务所需要时间time
  • 为了方便计算,时间全部换成来计算
  • 统计并筛选所有办理业务的人,剔除17:00以后到达的人,按照到达时间排序
  • 如果顾客到达时间come大于窗口空闲时间windowTime,就可以直接办理业务,无需等待,否则等待总时间res += (windowTime - come)
  • 最终 等待总时间res/60/ 办理业务有效人数 = 人均等待时间
  • 注意res按秒计算,先换成分钟,再求平均等待时间

代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
struct node{
    int come;//到达时间
    int time;//办理业务所需要时间
};
int cmp(node a, node b){
    return a.come < b.come;
}
int main()
{
    int n, k;//n个人 k个窗口
    scanf("%d %d", &n, &k);
    vector<node> custom;
    for(int i=0; i<n; i++){
        int hh,mm,ss,time;
        scanf("%d:%d:%d %d", &hh, &mm, &ss, &time);
        int cometime = hh*3600 + mm*60 + ss;
        if(cometime > 61200)//顾客来的时间晚于17:00 无效 直接跳过,无法办理
            continue;
        node temp;
        temp.come = cometime;
        temp.time = time*60;
        custom.push_back(temp);
    }
    sort(custom.begin(), custom.end(), cmp);
    vector<int> windowTime(k, 28800);//28800代表早上八点
    double res = 0.0;
    for(int i=0; i<custom.size(); i++){
        int minWindow=0;//最早结束的窗口 最早结束的窗口时间
        for(int j=1; j<k; j++){
            if(windowTime[minWindow] > windowTime[j]){
                minWindow = j;
            }
        }
        if(windowTime[minWindow] <= custom[i].come){//顾客来的时候就有空闲窗口
            windowTime[minWindow] = custom[i].come + custom[i].time;
        }else{//顾客来的时候需要等待
            res += (windowTime[minWindow] - custom[i].come);//顾客等待时间
            windowTime[minWindow] +=  custom[i].time;//更新窗口空闲时间
        }
    }
    if(custom.size() == 0){//有效人数为0,直接输出,除以0无意义
        printf("0.0");
    }else{
        printf("%.1f", res/60.0/custom.size());
    }
    return 0;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Queueing theory is a mathematical study of waiting lines or queues that arise in various real-life scenarios, such as customer service, traffic congestion, hospital emergency rooms, and telecommunications networks. Basic queueing theory involves the following concepts: 1. Arrival Process: This is the process of customers arriving at the queue. The arrival process can be modeled using different distributions, such as Poisson or exponential. 2. Service Process: This is the process of serving customers in the queue. The service process can also be modeled using different distributions, such as Poisson or exponential. 3. Queue Length: This is the number of customers waiting in the queue at any given time. 4. Queue Occupancy: This is the proportion of time that the server is busy serving customers. 5. System Capacity: This is the maximum number of customers that the system can handle at any given time. 6. Utilization: This is the proportion of time that the server is busy serving customers compared to the total time. 7. Waiting Time: This is the time that a customer spends waiting in the queue before being served. 8. Service Time: This is the time that a customer spends being served by the server. 9. Queueing Models: There are different queueing models that can be used to analyze queueing systems, such as the M/M/1 model, M/M/c model, M/G/1 model, and M/D/1 model. 10. Performance Measures: Different performance measures can be used to evaluate queueing systems, such as average waiting time, average queue length, and system throughput.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值