【状压】Corn Fields POJ3254

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K


Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.






题目大意:给出一个M*N的地图,1表示土地肥沃,0表示贫瘠,现在要在这些肥沃的土地上面种一些东西,但是不能连续种两块,也就是说你种东西的土地的任意两个之间没有公共边,求出可行方案的数目




做了几道状压DP了,终于做出了些感觉,不过还是手残+脑残了。。。。。


用 f [ i ] [ S ] 表示第 i 行 状态为 S 的方案数,

则方程就为  f [ i ] [ S ] = ∑ f [ i - 1 ] [ s t ]   (S和st满足题目要求,即没有公共边,并且都要在肥沃的土地上)


注意题目要求,取模!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


交了三次,前两次都是没取模!

    /*http://blog.csdn.net/jiangzh7 
    By Jiangzh*/  
    #include<cstdio>  
    #include<iostream>  
    using namespace std;  
    typedef long long LL;  
    const int N=15;  
    const int mod=100000000;  
    int n,m;  
    int map[N];  
    int a[1<<N],Cnt;  
    LL f[N][1<<N];  
      
    void PT(int s)//Debug  
    {  
        int a[N];  
        for(int i=m;i>=1;i--)  
        {  
            a[i]=s&1;  
            s>>=1;  
        }  
        for(int i=1;i<=m;i++) printf("%d",a[i]);  
        puts("");  
    }  
      
    void read()  
    {  
        scanf("%d%d",&n,&m);  
        for(int i=1;i<=n;i++)  
            for(int j=0;j<m;j++)  
            {  
                int x;scanf("%d",&x);  
                if(x) map[i]|=(1<<j);  
            }  
    }  
      
    void dfs(int s,int x)//生成一行中所有可行排列  
    {  
        if(x==m)  
        {  
            //PT(s);  
            a[++Cnt]=s;  
            return;  
        }  
        dfs(s<<1,x+1);  
        if(!(s&1)) dfs((s<<1)+1,x+1);  
    }  
      
    bool could(int i,int s1,int s2)  
    {  
        if((s1&map[i])!=s1) return false;  
        if((s2&map[i-1])!=s2) return false;  
        if((s1&s2)!=0) return false;  
        return true;  
    }  
      
    void work()  
    {  
        dfs(0,0);  
        for(int t=1,S=a[t];t<=Cnt;t++,S=a[t])  
        if((S&map[1])==S) f[1][S]++;  
        for(int i=2;i<=n;i++)  
        for(int t=1,S=a[t];t<=Cnt;t++,S=a[t])  
        for(int k=1,st=a[k];k<=Cnt;k++,st=a[k])  
        {  
            //printf("S:");PT(S);printf("st:");PT(st);  
            if(could(i,S,st))  
            {  
                f[i][S]+=f[i-1][st];  
                f[i][S]%=mod;  
                //printf("%d\n",f[i][S]);  
            }  
            //puts("");  
        }  
        LL res=0;  
        for(int t=1,S=a[t];t<=Cnt;t++,S=a[t])res+=f[n][S];  
        cout<<res%mod<<endl;  
    }  
      
    int main()  
    {  
        freopen("poj3254.in","r",stdin);  
        freopen("poj3254.out","w",stdout);  
        read();  
        work();  
        return 0;  
    }  


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值