POJ——3253题 Fence Repair

Fence Repair

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 66577 Accepted: 21929

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

这一题其实是运用了霍夫曼编码的原则,简单说就是将用到次数最少的数放在树的最底层,用到次数最多的放在最高层,如果想要多了解可以百度搜一下霍夫曼编码

AC源码如下:

#include<iostream>
#include<algorithm>
using namespace std;
int L[100000],n;
int main()
{
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>L[i];
	}
	long long ans=0;
	while(n>1){
		int min1=0,min2=1;
		if(L[min1] > L[min2])swap(min1,min2);
		for(int i = 2;i < n;i++){
			if(L[i]<L[min1]){
				min2=min1;
				min1=i;
			}else if(L[i] < L[min2]){
				min2=i;
			}
		}
		int t=L[min1]+L[min2];
		ans+=t;
		L[min1]=t;
		L[min2]=L[n-1];
		n--;
	}
	cout<<ans<<endl;
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值