poj2299--Ultra-QuickSort

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 40285 Accepted: 14529

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

Waterloo local 2005.02.05
给出n个数,每次只能交换两个相邻的数,交换最少次使得这n个数由小到大
这样交换,从第一个数开始,统计在这个数之前,且比这个数大的,一步一步的交换,使(包括这个数在内的)已交换的数是有序的,也就是说由左至右统计逆序数,
逆序数 = 在一串数中(对于每一位的,在该位之前且比这个数大的)个数的和 ;
同样也就可以理解为树状数组中统计每一位的值,该值为(在这一位之前,且比这个数小的),由这个数的序号-该值,最后累加得到整体的逆序数

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
map <int,int> s;
int c[500010] , a[500010] , b[500010];
int lowbit(int x)
{
    return x & -x ;
}
void add(int i,int n)
{
    while( i <= n )
    {
        c[i]++ ;
        i += lowbit(i) ;
    }
}
int sum(int i)
{
    int a = 0 ;
    while( i )
    {
        a += c[i] ;
        i -= lowbit(i) ;
    }
    return a ;
}
int main()
{
    int i , n , num ;
    while(scanf("%d", &n) && n)
    {
        memset(c,0,sizeof(c));
        num = 0 ;
        for(i = 0 ; i < n ; i++)
        {
            scanf("%d", &a[i]);
            b[i] = a[i] ;
        }
        sort(a,a+n);
        for(i = 0 ; i < n ; i++)
            s[ a[i] ] = i+1 ;
        for(i = 0 ; i < n ; i++)
        {
            num += ( i-sum( s[ b[i] ] ) ) ;
            add(s[ b[i] ],n);
        }
        printf("%d\n", num);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值