UVa12096集合栈计算机(集合操作)

刘汝佳紫书例题5-5  P115

Background from Wikipedia: “Set theory is a
branch of mathematics created principally by the
German mathematician Georg Cantor at the end of
the 19th century. Initially controversial, set theory
has come to play the role of a foundational theory
in modern mathematics, in the sense of a theory
invoked to justify assumptions made in mathematics
concerning the existence of mathematical objects
(such as numbers or functions) and their properties.
Formal versions of set theory also have a foundational
role to play as specifying a theoretical ideal
of mathematical rigor in proofs.”
Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to
construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under
construction, and they need you to simulate it in order to verify the operation of the prototype.
The computer operates on a single stack of sets, which is initially empty. After each operation, the
cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the
number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT,
and ADD.
• PUSH will push the empty set {} on the stack.
• DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
• UNION will pop the stack twice and then push the union of the two sets on the stack.
• INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
• ADD will pop the stack twice, add the first set to the second one, and then push the resulting set
on the stack.
For illustration purposes, assume that the topmost element of the stack is
A = {{}, {{}}}
and that the next one is
B = {{}, {{{}}}}
For these sets, we have |A| = 2 and |B| = 2. Then:
• UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.
• INTERSECT would result in the set {{}}. The output is 1.
• ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.
Input
An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each
test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of
the five commands. It is guaranteed that the SetStack computer can execute all the commands in the
sequence without ever popping an empty stack.
Output
For each operation specified in the input, there will be one line of output consisting of a single integer.
This integer is the cardinality of the topmost element of the stack after the corresponding command
has executed. After each test case there will be a line with ‘***’ (three asterisks).
Sample Input
2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT
Sample Output
0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***

【分析】集合栈计算机

把集合映射成数字,集合里套集合,就转变成装数字了

这里需要一个vector保存不同的集合,每个元素是set,下标代表集合的编号。

还需要一个map映射,帮助快速得到集合的编号

另外需要一个stack模拟本题过程。


这里用到了几个比较实用的STL函数:

set_union             求并集
set_intersection   求交集

【代码】:

#include<bits/stdc++.h>
using namespace std;
vector<set<int> >vec;//int编号映射集合
map<set<int>,int>M;
stack<int>sta;
void push(set<int>S)
{
    if(vec.size()==0||vec[M[S]]!=S){
        M[S]=vec.size();
        vec.push_back(S);
    }
    sta.push(M[S]);
}
void uia(int flag)
{
    int u=sta.top();sta.pop();
    int v=sta.top();sta.pop();
    set<int>S1;
    if(flag==0)
        set_union(vec[u].begin(),vec[u].end(),vec[v].begin(),vec[v].end(),inserter(S1,S1.begin()));
    if(flag==1)
        set_intersection(vec[u].begin(),vec[u].end(),vec[v].begin(),vec[v].end(),inserter(S1,S1.begin()));
    if(flag==2)
    {
        S1=vec[v];
        S1.insert(u);
    }
    push(S1);
}
int main()
{
    int T,n;
    string s;
    set<int>S;
    cin>>T;
    while(T--)
    {
        M.clear();
        vec.clear();
        while(!sta.empty())sta.pop();
        cin>>n;
        while(n--)
        {
            cin>>s;
            if(s[0]=='P')
                push(S);
            if(s[0]=='D'&&!sta.empty())
                sta.push(sta.top());
            if(s[0]=='U')uia(0);
            if(s[0]=='I')uia(1);
            if(s[0]=='A')uia(2);
            cout<<vec[sta.top()].size()<<endl;
        }
        cout<<"***"<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值