POJ 3121 The SetStack Computer

23 篇文章 0 订阅
16 篇文章 0 订阅
The SetStack Computer
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 995 Accepted: 206
Description

Background from Wikipedia: "Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics, in the sense of a theory invoked to justify assumptions made inmathematics concerning the existence of mathematical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal of mathematical rigor in proofs."

Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets instead of numbers. The initial Set-Stack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype.

The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT, and ADD.
PUSH will push the empty set {} on the stack.
DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).
UNION will pop the stack twice and then push the union of the two sets on the stack.
INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.
ADD will pop the stack twice, add the first set to the second one, and then push the resulting set on the stack.
For illustration purposes, assume that the topmost element of the stack is
A = {{}, {{}}}

and that the next one is
B = {{}, {{{}}}}.

For these sets, we have |A| = 2 and |B| = 2. Then:
UNION would result in the set { {}, {{}}, {{{}}} }. The output is 3.
INTERSECT would result in the set { {} }. The output is 1.
ADD would result in the set { {}, {{{}}}, {{},{{}}} }. The output is 3.

Input

An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each test case contains the number of operations 0 ≤ N ≤ 2 000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.
Output

For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with *** (three asterisks).
Sample Input

2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT
Sample Output

0
0
1
0
1
1
2
2
2
***
0
0
1
0
0

***



套娃套娃,好可爱的套娃。。。


集合的知识点,将集合映射成ID,必须对集合的概念搞清楚,集合的知识好弯。。只是到了能看懂别人代码的程度,自己写怕是写不出来。。。

<pre name="code" class="cpp">#include <iostream>
#include <set>
#include <vector>
#include <map>
#include <stack>
#include <algorithm>
#include <fstream>
using namespace std;
typedef set<int> Set;
vector<Set> setcache;
map<Set,int> IDcache;

#define ALL(x) x.begin(),x.end()
#define INS(x) inserter(x,x.begin())
int ID(Set x)
{
    if(IDcache.count(x))
        return IDcache[x];
    setcache.push_back(x);
        return IDcache[x]=setcache.size()-1;
}
int main(void)
{
   // fstream cin("E.txt");
    stack<int> s;
    int n;
   cin>>n;
   while(n--)
   {
       int m;
       cin>>m;
       for(int i=1;i<=m;i++)
       {
           string os;
           cin>>os;
           if(os=="PUSH") s.push(ID(Set()));
           else if(os=="DUP") s.push(s.top());
           else
           {
               Set x1=setcache[s.top()];s.pop();
               Set x2=setcache[s.top()];s.pop();
               Set x;
               if(os=="UNION") set_union(ALL(x1),ALL(x2),INS(x));
               if(os=="INTERSECT") set_intersection(ALL(x1),ALL(x2),INS(x));
               if(os=="ADD")
               {
                   x=x2;
                   x.insert(ID(x1));
               }
               s.push(ID(x));
           }
           cout<<setcache[s.top()].size()<<endl;
       }
       cout<<"***"<<endl;
   }
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值