SDOI

HDU 5499 SDOI(sort+结构体)
Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI. $ n ( n \leq 100 )$ people comes to the Select and there is $ m (m \leq 50)$ people who can go to the NOI. 

According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is $300$. 

All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is $x$.(it is promised that not all person in one round is 0,in another way,$x > 0$). So for this round,everyone's final mark equals to his/her original $mark * ( 300 / x )$. 

After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as $0.3 * round1's$ final mark + $0.7 * round2's$ final mark.It is so great that there were no two persons who have the same Ultimate mark. 

After we got everyone's Ultimate mark.We choose the persons as followed: 

To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams. 

1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team. 
2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team. 

Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing. 
 

Input

There is an integer $T(T \leq 100)$ in the first line for the number of testcases and followed $T$ testcases. 

For each testcase, there are two integers $n$ and $m$ in the first line$(n \geq m)$, standing for the number of people take part in SDOI and the allowance of the team.Followed with $n$ lines,each line is an information of a person. Name(A string with length less than $20$,only contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than $300$) separated with a space. 

 

Output

For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks. 

Followed $m$ lines,every line is the name of the team with their Ultimate mark decreasing.
 

Sample Input

       
       
2 10 8 dxy male 230 225 davidwang male 218 235 evensgn male 150 175 tpkuangmo female 34 21 guncuye male 5 15 faebdc male 245 250 lavender female 220 216 qmqmqm male 250 245 davidlee male 240 160 dxymeizi female 205 190 2 1 dxy male 300 300 dxymeizi female 0 0
 

Sample Output

       
       
The member list of Shandong team is as follows: faebdc qmqmqm davidwang dxy lavender dxymeizi davidlee evensgn The member list of Shandong team is as follows: dxymeizi Hint For the first testcase: the highest mark of Round1 if 250,so every one's mark times(300/250)=1.2, it's same to Round2. The Final of The Ultimate score is as followed faebdc 298.20 qmqmqm 295.80 davidwang 275.88 dxy 271.80 lavender 260.64 dxymeizi 233.40 davidlee 220.80 evensgn 201.00 tpkuangmo 29.88 guncuye 14.40 For the second testcase,There is a girl and the girl with the highest mark dxymeizi enter the team, dxy who with the highest mark,poorly,can not enter the team.
 

先算出每个人的总成绩然后找有没有女生如果有找到最大的然后输出前几名 如果没有直接输出前几名
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
using namespace std;  
struct Node  
{  
    char name[30];  
    char sex[10];  
    double r1,r2;  
    double score;  
 }a[110];  
 int cmp1(Node a,Node b)  
 {  
    return a.r1>b.r1;      
 }  
 int cmp2(Node a,Node b)  
 {  
    return a.r2>b.r2;  
 }  
 int cmp3(Node a,Node b)  
 {  
    return a.score >b.score;   
  }   
int main()  
{  
    int t,n,m;  
    double m1,m2;   
    scanf("%d",&t);  
    while(t--)  
    {     
        int f=0;  
        int f1=0;
		int k;  
        scanf("%d%d",&n,&m);  
        if(!m)  
            continue;   
        for(int i=1;i<=n;i++)  
        {  
            scanf("%s %s %lf %lf",a[i].name,a[i].sex,&a[i].r1,&a[i].r2);
        }       
        sort(a+1,a+n+1,cmp1);  
        m1=300.0/a[1].r1;
        sort(a+1,a+n+1,cmp2);          
        m2=300.0/a[1].r2;   
        for(int i=1;i<=n;i++)          
            a[i].score=0.3*m1*a[i].r1+0.7*m2*a[i].r2; //成绩的计算      
        sort(a+1,a+n+1,cmp3);  
        printf("The member list of Shandong team is as follows:\n");     
        for(int i=1;i<=n;i++)  
        {  
            if(strcmp(a[i].sex,"female")==0)  
            {  
                f=1;k=i;break;  
            }  //判断是否有女生
        }  
        if(f)  
        {  
            if(k<=m)  //判断哪个女生是否在前中如果在就直接输出前m名
            {  
                for(int i=1;i<=m;i++)  
                {  
                    printf("%s\n",a[i].name);  
                }  
            }  
            else  
            {  
                for(int i=1;i<m;i++) //女生不在前m名先输出前m名再输出女生 
                {  
                    printf("%s\n",a[i].name);   
                }  
                printf("%s\n",a[k].name);  
            }  
        }  
        else  
        {  
            for(int i=1;i<=m;i++)  
            {  
                printf("%s\n",a[i].name);  
            }  
        }  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值