River Hopscotch

                River Hopscotch

Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input
Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input
25 5 2
2
14
11
21
17
Sample Output
4
Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
题意就是有有L长的河河中间有n个石头拿走了m个石头让拿走石头后的最小距离最大化
把拿走石头后的最小距离进行二分然后进行比较当那个距离左走的最小石头数和n-m个相同时就是满足的

#include<cstdio>
#include<algorithm>
using namespace std;
int L,n,m;
int num[50055];
bool jugde(int mid){
    int last=0;//现在所在的位置 
    int sum=0;
    for(int i=0;i<n;i++){
        if(num[i]-last<mid){//如果这个位置的距离大于两个石头之间的距离直接跳过去 
            continue;
        }
        else{//否则所剩的石头数加一现在的距离变为所在的位置 
            sum++;last=num[i];
            if(L-num[i]<mid)break; //到岸上的距离也小于mid就直接上岸 

        }
    }
    return sum>=n-m;//石头剩的多了距离取小了 
}
int main(){
    while(~scanf("%d %d %d",&L,&n,&m)){
        for(int i=0;i<n;i++)
            scanf("%d",&num[i]);
        sort(num,num+n);
        int l=0;
        int r=L;
        int ans=0;
        while(l<=r){
            int mid=(l+r)/2;//二分牛每次走的最小距离 
            if(jugde(mid)){
                ans=mid;
                l=mid+1;
            }
            else{
                r=mid-1;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值