POJ 1308 Is It A Tree?

    以前做过这道题,是用并查集判断环做出来的。昨天晚上临走前看这道题时,感觉完全不需要用并查集,于是就又写了一遍,没用到并查集,完全就是用树的定义来写的。不过需要注意的是,空树也是一颗树,即0 0也是一棵树,这点太难想了。。。。

  根据树的定义,在有n个结点的树中,只能有n-1条边,多了或者少了都不是树;只有一个入度为0的点;其他点的入度都为1;根据这些就可以判断是否是一棵树。题目:

s It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14027 Accepted: 4854

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
const int N=10005;
int in[N],father[N],is[N];
int main(){
	freopen("1.txt","r",stdin);
	int x,y,k=0,a,b;
	bool flag;
	int mmax=0,numedge=0;
	while(scanf("%d%d",&a,&b)){
	  if(a==-1&&b==-1)break;
	  if(a==0&&b==0){
	     printf("Case %d is a tree.\n",++k);
		 continue;
	  }
	  memset(is,0,sizeof(is));
	  memset(in,0,sizeof(in));
	  mmax=0;numedge=0;
	  flag=true;
	   is[a]=1;is[b]=1;
       in[b]++;
	   numedge++;
	   if(a>mmax)mmax=a;
	   if(b>mmax)mmax=b;
       while(scanf("%d%d",&x,&y)){
	     if(x+y==0)break;
		 is[x]=1;is[y]=1;
		 in[y]++;
		 numedge++;
		 if(x>mmax)mmax=x;
		 if(y>mmax)mmax=y;
		 if(in[y]>1){
		   flag=false;
		 }
	   }
	   if(flag==false){
	     printf("Case %d is not a tree.\n",++k);
		 continue;
	   }
	   int numzero=0,numpoint=0;
	   for(int i=0;i<=mmax;++i){
		   if(is[i]){
		     numpoint++;
			 if(in[i]==0)
				 numzero++;
		   }
	   }
	   if(numzero==0||numzero>1){
	     flag=false;
	   }
	   if(numpoint-numedge!=1)flag=false;
	   if(flag==false){
	     printf("Case %d is not a tree.\n",++k);
	   }
	   else{
	     printf("Case %d is a tree.\n",++k);
	   }
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值