HDU 2795 Billboard 线段树

    题意比较简单,就是贴海报,从上往下贴,优先贴上面的,只有上面贴不下的时候,贴下面。

   方法:用普通方法的话会超时,虽然数据只有20万,时间为8000ms,但是后台数据必定相当变态,否则不会给这么长时间。这道题还是很容易想到用线段树的,只需要加一个变量value,代表的是该区间的可利用的最大值,在查找的时候更新一下就可以了。题目:

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3164    Accepted Submission(s): 1522


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 
ac代码:

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
const int N=1000005;
int h,w;
struct tree{
	int left,right,value;
	int getmid(){
	  return (left+right)/2;
	}
}tt[N];
void built_tree(int lp,int rp,int pos){ 
	tt[pos].left=lp;
	tt[pos].right=rp;
	tt[pos].value=w;
	if(lp==rp)return ;
	int mid=tt[pos].getmid();
	built_tree(lp,mid,pos*2);
	built_tree(mid+1,rp,pos*2+1);
}
int max(int a,int b){
	return a>b?a:b;
}
int find(int hx,int lp,int rp,int pos){
	if(lp==rp){
		tt[pos].value-=hx;
		return lp;
	}
	int mm=tt[pos].getmid();
	int res=0;
	if(tt[pos*2].value<hx)
		res=find(hx,mm+1,rp,pos*2+1);
	else
		res=find(hx,lp,mm,pos*2);
	tt[pos].value=max(tt[pos*2].value,tt[pos*2+1].value);
	return res;
}
int main(){
	//freopen("1.txt","r",stdin);
	int n;
	while(~scanf("%d%d%d",&h,&w,&n)){
	  if(h>n) h=n;
	  built_tree(1,h,1);
	  int hx;
	  while(n--){
	    scanf("%d",&hx);
		if(tt[1].value<hx)
			printf("-1\n");
		else{
		    int y=find(hx,1,h,1);
			printf("%d\n",y);
		}
	  }
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值