蓝桥杯 VIP 基础练习 报时助手

 基础练习 报时助手  
时间限制:1.0s   内存限制:512.0MB
       
问题描述
  给定当前的时间,请用英文的读法将它读出来。
  时间用时h和分m表示,在英文的读法中,读一个时间的方法是:
  如果m为0,则将时读出来,然后加上“o'clock”,如3:00读作“three o'clock”。
  如果m不为0,则将时读出来,然后将分读出来,如5:30读作“five thirty”。
  时和分的读法使用的是英文数字的读法,其中0~20读作:
  0:zero, 1: one, 2:two, 3:three, 4:four, 5:five, 6:six, 7:seven, 8:eight, 9:nine, 10:ten, 11:eleven, 12:twelve, 13:thirteen, 14:fourteen, 15:fifteen, 16:sixteen, 17:seventeen, 18:eighteen, 19:nineteen, 20:twenty。
  30读作thirty,40读作forty,50读作fifty。
  对于大于20小于60的数字,首先读整十的数,然后再加上个位数。如31首先读30再加1的读法,读作“thirty one”。
  按上面的规则21:54读作“twenty one fifty four”,9:07读作“nine seven”,0:15读作“zero fifteen”。
输入格式
  输入包含两个非负整数h和m,表示时间的时和分。非零的数字前没有前导0。h小于24,m小于60。
输出格式
  输出时间时刻的英文。
样例输入
0 15
样例输出
zero fifteen
模拟题,将数字转换成英文的表示,对于不同的数字,有不同的表示形式,为了方便起见,定义一个string数组并初始化,内容自然就是从0-20的英文单词,以及30,40,50的英文单词,这是最少的不重复的英文单词,其他的单词都是可以通过这些单词的组合来表示,也就是说,假如要输出0-20,直接输出数组中的值就好,如果大于20,就得把这个数分解,高位存到a,低位存到b,然后依次输出高位所表示的英文,低位所表示的英文就行了,只要完成了这一步,接下来就简单判断一下题目中给出的条件就可以了。

#include <iostream>
#include <cmath>
#include <stdio.h>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <iomanip>
#include <algorithm>
#include <memory.h>
using namespace std;
int m,h;
string eng[]={"zero","one", "two","three","four","five","six","seven","eight","nine","ten",
"eleven","twelve","thirteen","fourteen","fifteen","sixteen","seventeen","eighteen","nineteen","twenty",
"thirty","forty","fifty"
};
string r=" o'clock";

void num_to_eng(int num)
{
    int a,b;
    a=num/10;
    b=num%10;
    if(num<=20)
    {
        cout<<eng[num];
    }
    else
    {
        cout<<eng[a+18];
        if(b!=0)
        {
            cout<<' '<<eng[b];
        }
    }
}



void output()
{
    if(m==0)
    {
        num_to_eng(h);
        cout<<r<<endl;
    }
    else
    {
        num_to_eng(h);
        cout<<' ';
        num_to_eng(m);
        cout<<endl;
    }

}

int main()
{
    cin>>h>>m;
    output();
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值