POJ 3071 Football 概率DP 二进制优化

 
 
这道题目所描述的情形和归并排序很类似,都是两两合并,实际上里面还包含了一些二进制的知识。 我们设dp[i][j]表示在第i轮j组胜出的概率,那么很明显,j组必须在第i-1轮胜出,j本轮的竞争对手也一定要在i-1轮胜出,根据概率论的知识,我们可以知道在i轮胜出的概率就是他在那一轮战胜每一个对手的概率和,因为他只要赢一个队就能晋级。假设竞争对手为k,dp[i][j]=sigma(dp[i-1][j]*dp[i-1][k]*win[j][k]),其中win是概率。 那么问题来了,怎么判断k与j能不能成为竞争对手,不管通过什么手段实现,这里有一种较为简单的方式。假设队伍的编号从0开始,那么观察这些编号的二进制形式,可以发现:在第一轮,只有当两个二进制数字的最低位不同,并且其它都相同的队伍才具有竞争关系,比如2(10)和3(11)。经过这轮合并后,我们就必须考察二进制数字的倒数第二位,比如4(100)和7(111),实际上这是由于区间扩大了2倍,而不处于同一区间的队伍是不能作为对手的,于是,我们可以使用向右移位(或者除以2)的方法来处理,每次都去除最低位。为了确保满足除了最低位不同,其余位都相同,我们将一个移位后的数字与1抑或,看是否和另外一个数字相同即可。
Football
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4434Accepted: 2262

Description

Consider a single-elimination football tournament involving 2 n teams, denoted 1, 2, …, 2 n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner. Given a matrix P = [ pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2 n lines each contain 2 n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all ij, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:
P(2 wins)= P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4) = p21p34p23 + p21p43p24 = 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source

 
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;

const int maxn=130;

double dp[10][maxn];
double gl[maxn][maxn];



int main()
{
    int turn,n;
    double win;
    int ans;
    while(~scanf("%d",&turn)&&(turn!=-1))
    {
        n=pow(2,turn);
        ans=0;
        win=-1;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                //cin>>gl[i][j];
                scanf("%lf",&gl[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            dp[0][i]=1;
        }
        for(int i=1;i<=turn;i++)
        {
            for(int j=0;j<n;j++)
            {
                for(int k=0;k<n;k++)
                    if(((k>>(i-1))^1)==(j>>(i-1)))
                    dp[i][j]+=dp[i-1][j]*dp[i-1][k]*gl[j][k];
            }
        }
        for(int i=0;i<n;i++)
        {
            if(win<dp[turn][i])
            {
                win=dp[turn][i];
                ans=i;
            }
        }
        printf("%d\n",ans+1);

    }
    return 0;
}
 

查看原文:http://colorfulshark.cn/wordpress/football-1038.html
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值