题目1019:简单计算器

/*
题目描述:
    读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
输入:
    测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
输出:
    对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
样例输入:
1 + 2
4 + 2 * 5 - 7 / 11
0
样例输出:
3.00
13.36
*/
#include <iostream>
#include <fstream>
#include <string>
#include <sstream>
#include <cctype>
#include <stack>
#include <cstdlib>
#include <map>
#include <utility>

using namespace std;

int main()
{
    string str;
    map<char, int> opPriority;
    double a, b;

    opPriority.insert(pair<char, int>('+', 0));
    opPriority.insert(pair<char, int>('-', 0));
    opPriority.insert(pair<char, int>('*', 1));
    opPriority.insert(pair<char, int>('/', 1));

#ifndef ONLINE_JUDGE
    ifstream cin("d:\\OJ\\uva_in.txt");
#endif // ONLINE_JUDGE

    while (getline(cin, str)) {
        if (str == "0")
            break;

        istringstream line(str);
        string tmp;
        stack<double> s;
        stack<char> op;



        while (line >> tmp) {
            if (isdigit(tmp[0])) {
                s.push(atof(tmp.c_str()));
            } else {
                if (op.empty())
                    op.push(tmp[0]);
                else {
                    char ch = tmp[0];
                    char stackch = op.top();
                    while (!op.empty() && opPriority[ch] <= opPriority[stackch]) {

                        op.pop();
                        if (stackch == '+') {
                            a = s.top();
                            s.pop();
                            b = s.top();
                            s.pop();
                            a = a + b;
                            s.push(a);
                        } else if (stackch == '-') {
                            a = s.top();
                            s.pop();
                            b = s.top();
                            s.pop();
                            a = b - a;
                            //cout << "a:" << a <<endl;
                            s.push(a);
                        } else if (stackch == '*') {
                            a = s.top();
                            s.pop();
                            b = s.top();
                            s.pop();
                            a = a * b;
                            s.push(a);
                        } else if (stackch == '/') {
                            a = s.top();
                            s.pop();
                            b = s.top();
                            s.pop();
                            a = b / a;

                            s.push(a);
                        }
                        if (!op.empty())
                            stackch = op.top();
                    }
                    op.push(ch);

                }
            }
        }


        while (!op.empty()) {
            char stackch = op.top();
            op.pop();
            if (stackch == '+') {
                a = s.top();
                s.pop();
                b = s.top();
                s.pop();
                a = a + b;
                s.push(a);
            } else if (stackch == '-') {
                a = s.top();
                s.pop();
                b = s.top();
                s.pop();
                a = b - a;
                s.push(a);
            } else if (stackch == '*') {
                a = s.top();
                s.pop();
                b = s.top();
                s.pop();
                a = a * b;

                s.push(a);
            } else if (stackch == '/') {
                a = s.top();
                s.pop();
                b = s.top();
                s.pop();
                a = b / a;

                s.push(a);
            }
        }

        double ans = s.top();
        s.pop();
        cout.precision(2);
        cout << fixed << ans <<endl;
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值