简单计算器(栈的入门)

简单计算器

题目:

简单计算器
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34884 Accepted Submission(s): 12621

Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output
3.00
13.36

思路:

这道题因为是没有括号的,因而建立一个栈,若遇到加号把数字入栈,若遇到减号则转换为负数后入栈,若遇到乘除则就近直接计算后再把数值写回栈尾。最后再将栈内数字全部相加得到最后的结果。

解答:

栈的思想,数组直接做:

#include <bits/stdc++.h>

using namespace std;
double ans[1002];
int tail;  //尾数下标

int main()
{
    int temp1,temp2;  //左、右操作数
    int i;
    char c1,c2;
    double ret;

    while(scanf("%d%c",&temp1,&c2)!=EOF){
        if(temp1==0 && c2 == '\n')
            break;  //如果输入只有0时结束
        tail = 0;  //注意每次都要置0;
        ret = 0;  //注意每次都要置0;
        ans[++tail] = 1.0*temp1;  //转换为浮点数
        while(scanf("%c %d%c",&c1,&temp2,&c2)!=EOF){
            if(c1 == '+'){
                ans[++tail] = 1.0*temp2;  //如果是加号直接入栈
            }else if(c1 == '-'){
                ans[++tail] = -1.0*temp2;  //如果是负号转换为负数再入栈
            }else if(c1 == '*'){
                ans[tail] *= temp2;  //如果是乘号则更新栈尾数
            }else if(c1 == '/' && temp2 != 0){
                ans[tail] /= temp2;  //如果是除号则更新栈尾数
            }else
                break;
            if(c2 != ' ')
                break;  //如果最后一个字符不是空格则输入结束
        }
        for(i = 1; i<=tail; i++){
            ret += ans[i];  //把栈里的数都加起来,求和
        }
        printf("%.2f\n",ret);
    }
    return 0;
}

修改了一下换行符或空格的输入判断,
纯纯的栈来解决是更加简便的:

#include <bits/stdc++.h>

using namespace std;

const int MAX = 200;

stack <double> s;

int main(){
    int a;
    while(scanf("%d ",&a) && a!=0){
        s.push(1.0 * a);
        char symbol,space;
        double num;
        double ans = 0;
        while(scanf("%c %lf%c",&symbol,&num,&space)!=EOF){
            if(symbol == '+'){
                s.push(1.0 * num);
            }
            else if(symbol == '-')
                s.push(-1.0 * num);
            else if(symbol == '*'){
                double temp = s.top() * num;
                s.pop();
                s.push(temp);
            }else if(symbol == '/'){
                double temp = s.top() / num;
                s.pop();
                s.push(temp);
            }
            if(space != ' '){
                break;
            }
        }
        while(!s.empty()){
            ans += s.top();
            s.pop();
        }
        printf("%.2lf\n",ans);
    }
    return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值