POJ2253 Frogger

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33139 Accepted: 10656

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:两只青蛙坐标(前两个),以及一些石头的坐标,第一只青蛙想通过石头调到第二只青蛙那里去,可能有很多条路径,对于每条路径求出其中最长的一段,然后希望找出所有最长段中的最短的最长段。


可以使用dijkstra变形或者floyd变形的方法来求。

#include <iostream>
#include <stdio.h>
#include <string>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <queue>

using namespace std;

struct Node
{
    int x,y;
}f[222];
int n;
double mp[222][222];

double get(int a,int b,int c,int d)
{
    return sqrt( (a-c)*(a-c)+(b-d)*(b-d) );
}

void floyd()
{
    for(int k=0;k<n;k++)
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            if(mp[i][j]>mp[i][k] && mp[i][j]>mp[k][j])//枚举从i到j的中间过程时,每次保存最大分段的长度
            {
                mp[i][j]=max(mp[i][k],mp[k][j]);
            }
        }
}

int main()
{
    int ca=1;
    while(~scanf("%d",&n),n)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&f[i].x,&f[i].y);
        }

        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                mp[i][j]=get(f[i].x,f[i].y,f[j].x,f[j].y);
            }
        }

        floyd();

        printf("Scenario #%d\nFrog Distance = %.3f\n\n",ca++,mp[0][1]);
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值