【POJ】2115 - C Looooops(扩展欧几里得)

该博客讨论了如何利用扩展欧几里得算法解决POJ 2115题,即判断一个for循环的运行次数或是否为死循环。通过建立数学方程并转换,博主解释了如何将问题转化为求解线性同余方程,从而应用扩展欧几里得算法找到答案。
摘要由CSDN通过智能技术生成

点击打开题目

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23259 Accepted: 6391

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source




就是判断一个for循环能运行几次才退出的问题,或者是死循环无法退出,如果溢出了就再循环(无符号位)。

首先来列方程:A + C * x - (2^k)* y = d

然后就得出了:C * x + (-2^k)* y = d

也就是:a = C ,b = 2^k(这里的b应该变为正数,把负号移到y上面去,最后我们要求的是x的值,与y没有关系,真不行用一次换元法,把-y换掉,最后那个特解求一下相反数就行了)


然后用扩展欧几里得就行了。


代码如下;

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
__int64 exGCD(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
	if (b == 0)
	{
		x = 1;
		y = 0;
		return a;
	}
	__int64 g = exGCD(b,a%b,y,x);
	y -= a / b * x;
	return g;
}
int main()
{
	__int64 A,B,C,k;
	__int64 a,b,x,y,c,d;
	__int64 ans;
	while (~scanf ("%I64d %I64d %I64d %I64d",&A,&B,&C,&k) && (A || B || C || k))
	{
		a = C;
		b = (__int64)1 << k;
		d = B - A;
		c = exGCD(a,b,x,y);
		if (d % c != 0)
		{
			printf ("FOREVER\n");
			continue;
		}
		ans = x * d / c;		//通解为 ans + b / c * t 
		b = b / c;
		ans = (ans % b + b) % b;
		printf ("%I64d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值