poj 2115

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30183 Accepted: 8718

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766

FOREVER

题目大意:给出循环

for (variable = A; variable != B; variable += C)

variable%=2^i;

对于该循环求出需要循环多少次。

不难看出 (A+C*X)%2^k=B

也就转化为:A+C*X=B+2^k*Y

也就等价于:C*X-2^k*Y=B-A

相当于式子:AX+BY=C

也就是运用到了扩展欧几里得算法进行计算。(扩展欧几里得算法可以去百度查看)

代码:

#include<stdio.h>
#include<string.h>
long long gcd(long long a,long long b,long long &x,long long &y){
    if (b==0){
        x=1,y=0;
        return a;
    }
    long long q=gcd(b,a%b,y,x);
    y-=a/b*x;
    return q;
}
int main()
{
	long long a,b,c,k,s;
	while(scanf("%lld%lld%lld%lld",&a,&b,&c,&k)!=EOF)
	{
		if(a==0&&b==0&&c==0&&k==0)
		 break;
		long long A,B,C,ans,x,y;
		A=c;
		C=b-a;
		B=1LL<<k;//对于longlong型变量,需要这样写位运算,为此wa了好几次
		ans=gcd(A,B,x,y);//扩展欧几里得算法运用	
		if(C%ans)
		{
			printf("FOREVER\n");
		}
		else
		{
			x=(x*C/ans)%B;//计算出一个解
			x=(x%(B/ans)+(B/ans))%(B/ans);
			printf("%lld\n",x);//最小正整数解
		}
	}
	return 0;
}

算法感觉不是太好理解,不过可以先把他当做一个工具进行运用,毕竟有些思维不是短时间内能理解的

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值