【HDU 6103 Kirinriki】 & 尺取

Kirinriki

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 541 Accepted Submission(s): 204

Problem Description
We define the distance of two strings A and B with same length n is
disA,B=∑i=0n−1|Ai−Bn−1−i|
The difference between the two characters is defined as the difference in ASCII.
You should find the maximum length of two non-overlapping substrings in given string S, and the distance between them are less then or equal to m.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integers m : the limit distance of substring.
Then a string S follow.

Limits
T≤100
0≤m≤5000
Each character in the string is lowercase letter, 2≤|S|≤5000
∑|S|≤20000

Output
For each test case output one interge denotes the answer : the maximum length of the substring.

Sample Input
1
5
abcdefedcb

Sample Output
5

Hint
[0, 4] abcde
[5, 9] fedcb
The distance between them is abs(‘a’ - ‘b’) + abs(‘b’ - ‘c’) + abs(‘c’ - ‘d’) + abs(‘d’ - ‘e’) + abs(‘e’ - ‘f’) = 5

Source
2017 Multi-University Training Contest - Team 6

题意 : 给出一串字符串,从中选出两个不重叠的字符串,使得两个字符串的距离和 <= m 的最长字符串长度,A,B 串中的字符距离计算为 disA,B=∑i=0n−1|Ai−Bn−1−i|

题解 :

两个不重合的子串向中心一起延长会形成奇偶长度两种合串。枚举一下中心向外延伸,如果和超过了阈值弹掉中心处的位置。双指针维护。时间复杂度O(n^2)
另解:
枚举[1,i],[j,n]用同样方法往内缩。
时间复杂度O(n^2)

思路 : 在总字符串中依次挑选长度为 2 ~ nl 的子串,在满足距离和 sum <= m 的前提下,从两边往里缩进,正反各一次

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int MAX = 5e3 + 10;
char s[MAX];
int nl,m,ans;
void solve(){
    for(int i = 2; i <= nl; i++){
        int o = i / 2,l = 0,n = 0,sum = 0;
        for(int j = 0; j < o; j++){
           sum += abs(s[j] - s[i - j - 1]); // 从两边往里缩进
           if(sum <= m) n++,ans = max(ans,n);
           else{
                sum -= abs(s[l] - s[i - l - 1]);
                sum -= abs(s[j] - s[i - j - 1]);
                n--,j--,l++; // 一直到满足条件在缩进
           }
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d %s",&m,s);
        nl = strlen(s),ans = 0;
        solve(),reverse(s,s + nl),solve(); // 正反各一遍
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值