【HDU 6130 Kolakoski】& Kolakoski & 打表

Kolakoski

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 528 Accepted Submission(s): 275

Problem Description
This is Kolakosiki sequence: 1,2,2,1,1,2,1,2,2,1,2,2,1,1,2,1,1,2,2,1……. This sequence consists of 1 and 2, and its first term equals 1. Besides, if you see adjacent and equal terms as one group, you will get 1,22,11,2,1,22,1,22,11,2,11,22,1……. Count number of terms in every group, you will get the sequence itself. Now, the sequence can be uniquely determined. Please tell HazelFan its nth element.

Input
The first line contains a positive integer T(1≤T≤5), denoting the number of test cases.
For each test case:
A single line contains a positive integer n(1≤n≤107).

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.

Sample Input
2
1
2

Sample Output
1
2

Source
2017 Multi-University Training Contest - Team 7

Recommend
liuyiding | We have carefully selected several similar problems for you: 6132 6131 6130 6129 6128

题意 : Kolakoski 序列
思路 : 仔细观察会发现上面的 1,2 分别代表同一个序列把相同的合并后的长度,由此可根据前面的推出后面的了
1,2,2,1,1,2,1,2,2,1,2,2,1,1,2,1,1,2,2,1
1,22,11,2,1,22,1,22,11,2,11,22,1

AC代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e7 + 10;
typedef long long LL;
int a[MAX];
void init(){
    a[1] = 1;
    int nl = 1;
    for(int i = 1; i + nl < MAX; i++){
        if(a[i] == 1){
            if(a[i + nl - 1] == 1) a[i + nl] = 2;
            else a[i + nl] = 1;
        }
        if(a[i] == 2){
             a[i + nl] = a[i + nl - 1];
             if(a[i + nl] == 1) a[i + ++nl] = 2;
             else a[i + ++nl] = 1;
        }
    }
}
int main()
{
    init();
    int T,n; scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        printf("%d\n",a[n]);
    }
    return 0;
}

标程 & 打表:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e7 + 10;
typedef long long LL;
int a[MAX],x,o,p;
void init(){
    a[1] = x = 1,a[2] = a[3] = 2,o = p = 3;
    while(p < MAX){
        for(int i = 1; i <= a[o]; i++) a[++p] = x;
        ++o,x = 3 - x;
    }
}
int main()
{
    init();
    int T,n; scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        printf("%d\n",a[n]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值