Jungle Roads(最小生成树)

110 篇文章 3 订阅

题目


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
输入:
    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
输出:
    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
样例输入:
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
样例输出:
216
30

解题思路

这道题是典型的并查集+kruskal求最小生成树的题目,但是有两个难点:
  1. 要有比较好的英文理解能力,这也就是周末,读题就读了至少半个多小时才理解是什么意思:简单的说,就是在这几个城市中构建一个最小生成树,好让道路维修的成本最少
  2. 其次,是要处理输入输出,这个A代表第一个城市,B代表第二个城市,可以考虑将其转换成整形数据进行存储,就可以继续套用并查集+kruskal求最小生成树了
  3. 这次竟然还是在时间复杂度和空间复杂度上排第一,记录一下


AC代码

#include <stdio.h>
#include <stdlib.h>
 
struct road
{
    int u, v, cost;
};
 
int father[28];
 
 
int compare(const void *a, const void *b)
{
    const struct road *p = a;
    const struct road *q = b;
 
    return p->cost - q->cost;
}
 
int find_set(int x)
{
    while (x != father[x]) {
        x = father[x];
    }
 
    return x;
}
 
void union_set(int x, int y)
{
    int px, py;
    px = find_set(x);
    py = find_set(y);
 
    if (px != py) {
        father[px] = py;
    }
}
 
int main()
{
    int i, j, k, n, u, v, m, cost, mst;
    char ver1, ver2;
    struct road road[351];
 
    while (scanf("%d", &n) != EOF && n != 0) {
        for (i = 1; i <= n; i ++) {
            father[i] = i;
        }
 
        for (i = k = 0; i < n - 1; i ++) {
            getchar();
            scanf("%c %d", &ver1, &m);
            if (m == 0) {
                continue;
            }else {
                u = ver1 - 'A' + 1;
                for (j = 0; j < m; j ++) {
                    getchar();
                    scanf("%c %d", &ver2, &cost);
                    v = ver2 - 'A' + 1;
                    road[k].u = u;
                    road[k].v = v;
                    road[k].cost = cost;
                    k ++;
                }
            }
        }
 
        qsort(road, k, sizeof(road[0]), compare);
 
        for (i =mst = 0; i < k; i ++) {
            u = find_set(road[i].u);
            v = find_set(road[i].v);
            if (u != v) {
                mst += road[i].cost;
                union_set(u, v);
            }
        }
 
        printf("%d\n", mst);
    }
 
    return 0;
}
/**************************************************************
    Problem: 1154
    User: wangzhengyi
    Language: C
    Result: Accepted
    Time:10 ms
    Memory:908 kb
****************************************************************/

后记

周末的时候,看看电视写两道acm是件非常舒服的事情,加油
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值