Jungle Roads (HDU - 1301 )

Jungle Roads (HDU - 1301 )

这道题是我以前做的最小生成树专题里的一道题,但我那时候没做。。。。。比赛出了,后悔莫及。。。。


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Output

216
30

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题目翻译:


热带岛屿拉格日山的长者首领有个问题。几年前,大量的外国援助资金被用于修建村庄之间的公路。但是丛林无情地侵占了道路,所以庞大的道路网络过于昂贵而无法维护。长老会议必须选择停止维护一些道路。左上方的地图显示了所有正在使用的道路,以及每个月维护这些道路的aacms成本。当然,即使道路不像以前那么短了,也需要有办法通过维护好的道路在所有村庄之间通行。首席长老想告诉长老委员会,他们每个月能在aacms上花最少的钱来维护连接所有村庄的道路。这些村庄在上面的地图上标为A到I。右边的地图显示了维护最便宜的道路,每月216 aacms。你的任务是编写一个程序来解决这些问题。

输入由1到100个数据集组成,最后一行只包含0。每个数据集从一行开始,其中只包含一个数字n,即村庄的数量,1 < n < 27,这些村庄用字母表的前n个字母标记,大写。每个数据集由n-1行组成,以字母顺序的村庄标签开始。没有到最后一个村庄的队。每个村庄的每一行都以村庄的标签开始,后面跟着一个数字k,表示从这个村庄到村庄的道路,后面的标签都在字母表中。如果k大于0,这条线继续表示k条路的数据。每条道路的数据是道路另一端的村庄标签,后面是道路的每月aacms维护成本。维修费用为小于100的正整数。行中的所有数据字段都由单个空格分隔。这条公路网将始终允许在所有村庄之间通行。这一网络将永远不会超过75条道路。没有哪个村庄通往其他村庄的道路会超过15条(在字母表中是之前还是之后)。在下面的示例输入中,第一个数据集与上面的映射匹配。

每个数据集的输出为每一行一个整数:每个月维护连接所有村庄的道路系统的最低aacms成本。警告:一个检查所有可能道路的蛮力解决方案不会在一分钟内完成。

思路:典型的prim算法。

AC代码:

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <math.h>
#define MAX 1010
using namespace std;
struct node
{
    int a,b,step;
}s[MAX];
int pre[MAX];
bool cmp(node x,node y)
{
    return x.step<y.step;
}
int init()
{
    for(int i=0; i<=26; i++)
        pre[i]=i;
}
int getf(int x)
{
    if(pre[x]!=x)
        pre[x]=getf(pre[x]);
    return pre[x];
}
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        init();
        int t=0;
        for(int i=1; i<n; i++)
        {
            char ch1,ch2;
            int x,y;
            getchar();
            scanf("%c %d",&ch1,&x);
            for(int j=0; j<x; j++)
            {
                getchar();
                scanf("%c %d",&ch2,&y);
                s[t].a=ch1-'A';
                s[t].b=ch2-'A';
                s[t].step=y;
                t++;
            }
        }
        sort(s,s+t,cmp);
        int sum=0;
        for(int i=0; i<t; i++)
        {
            int p=getf(s[i].a);
            int q=getf(s[i].b);
            if(p!=q)
                pre[p]=q,sum+=s[i].step;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值