关闭

Linux scipy安装

标签: linuxpipscipy
2016人阅读 评论(0) 收藏 举报
分类:
某些情况下,Linux会缺少scipy的一些基础包,如lapack/blas等。网上搜到的一下教程颇为麻烦,在折腾一番之后,找到简易命令行。


只需要几个命令即可完成:


sudo apt-get install libblas-dev
sudo apt-get install liblapack-dev
sudo apt-get install gfortran
sudo apt-get install python-scipy
轻松搞定。




On Fedora, this works:
 yum install lapack lapack-devel blas blas-devel
 pip install numpy
 pip install scipy


Remember to install 'lapack-devel' and 'blas-devel' in addition to 'blas' and 'lapack' otherwise you'll get the error you mentioned or the the "numpy.distutils.system_info.LapackNotFoundError" error.


不知为何非要6.1.1的,redhat上。

sudo easy_install pip==6.1.1

1
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:13614次
    • 积分:307
    • 等级:
    • 排名:千里之外
    • 原创:16篇
    • 转载:1篇
    • 译文:2篇
    • 评论:0条