1082. Read Number in Chinese (25)【字符串处理】——PAT (Advanced Level) Practise

题目信息

1082. Read Number in Chinese (25)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B
Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output “Fu” first if it is negative. For example, -123456789 is read as “Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu”. Note: zero (“ling”) must be handled correctly according to the Chinese tradition. For example, 100800 is “yi Shi Wan ling ba Bai”.

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai

解题思路

注意细节

AC代码

#include <cstdio>
#include <string>
#include <cstring>
#include <vector>
using namespace std;
char num[][5] = {"ling", "yi", "er", "san", "si", "wu", "liu", "qi", "ba", "jiu"};
char step[][5] = {"", "Shi", "Bai", "Qian"};
char bigStep[][5] = {"", "Wan", "Yi"};
vector<string> ans, qans;
void show(string s, bool first)
{
    int i = 0, t = -1;
    while (i < s.size() && '0' == s[i]) ++i;
    t = i - 1;
    if (i != 0 && (ans.empty() || ans[ans.size() - 1] != "ling")) ans.push_back("ling");
    for (; i < s.size(); ++i){
        if (t + 1 != i) ans.push_back("ling");
        t = i;
        ans.push_back(num[s[i] - '0']);
        ans.push_back(step[s.size() - 1 - i]);
        while (i + 1 < s.size() && '0' == s[i + 1]) ++i;
        first = false;
    }
}
int main()
{
    char s[15];
    char *p = s;
    gets(s);
    int len = strlen(s);
    if (s[0] == '-'){
        ans.push_back("Fu");
        --len;
        ++p;
    }
    for (int i = 8; i >= 0; i -= 4){
        if (len > i){
            show(string(p, p + len - i), p == s);
            if (ans[ans.size() - 1] != "ling") ans.push_back(bigStep[i/4]);
            p += len - i;
            len -= len - i;
            if (strspn(p, "0") == len) break;
        }
    }
    for (int i = 0; i < ans.size(); ++i){
        if (ans[i] != "") qans.push_back(ans[i]);
    }
    for (int i = 0; i < qans.size() - 1; ++i){
        printf("%s ", qans[i].c_str());
    }
    printf("%s\n", qans[qans.size() - 1].c_str());
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值