训练3 习题22

题目:
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . <br>Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.<br><br>Notes and Constraints<br> 0 < T <= 100<br> 0.0 <= P <= 1.0<br> 0 < N <= 100<br> 0 < Mj <= 100<br> 0.0 <= Pj <= 1.0<br> A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6



思路:   01 背包问题     dp[i]表示偷价值为 i 时不被抓的概率  表达式为dp[j] = max(dp[j] , dp[j-m[i]] * (1-p[i]));求出不被逮捕的所能强盗的最大钱数。


#include <stdio.h>
#include <string.h>


int m[101];
double p[101],dp[10001];


int main()
{
    int t,n,i,j,sum;
    double P;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf %d",&P,&n);
        sum = 0;
        P = 1 - P;
        for(i = 0; i < n; i++)
        {
            scanf("%d %lf",&m[i],&p[i]);
            sum += m[i];
            p[i] = 1 - p[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        for(i = 0; i < n; i++)
            for(j = sum; j >= m[i]; j--)
                if(dp[j] < dp[j-m[i]]*p[i])
                    dp[j] = dp[j-m[i]]*p[i];
        for(i = sum; i >= 0&&dp[i] < P; i--);
        printf("%d\n",i);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值