Sightseeing

15 篇文章 0 订阅

Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.这里写图片描述

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

M lines, each with three integers A, B and L, separated by single spaces, with 1 ≤ A, B ≤ N, A ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.

The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

One line with two integers S and F, separated by a single space, with 1 ≤ S, F ≤ N and S ≠ F: the starting city and the final city of the route.

There will be at least one route from S to F.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 10^9 = 1,000,000,000.

Sample Input
2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

Sample Output
3
2
题意:
给你一个有向图,可能有重边,让你求从s到t最短路的条数,如果次短路的长度比最短路的长度多1,那么在加上次短路的条数。
思路:
使用dij算法,算最短路与次短路两种路径,当找出距离st最短的点的时候,然后进行更新,更新分四种情况:
1.新路径比最短路径长度要小,那么最短路和次短路的长度和次数都要更新。
2.新路径等于最短路的长度,那么只需要更新最短路的条数。
3.新路径比最短路要长但是比次短路要短,那么需要更新次短路的长度和条数。
4.新路径等于次短路径的长度,那么只需要更新次短路径的条数。

代码:

#include<iostream>
#include<cstring>
using namespace std;
#define inf 0x7f7f7f7f
int dis[1005][2];int  cnt[1005][2],head[1005],num;//dis[i][0]为最短路,dis[i][1]为次短路
bool flag[1005][2];
int m, n,x,y,ans;
struct node
{
    int en,len,next;
}E[1005*1005];
void init()
{
    num=0;memset(head,-1,sizeof(head));
}
void add(int st,int en,int len)
{
    E[num].en=en;E[num].len=len;
    E[num].next=head[st];head[st]=num++;
}
void dij(int st,int en)
{
    for(int i=1; i<=n; i++)
  {
    dis[i][0]=inf;
    dis[i][1]=inf;
  }
  memset(flag,false,sizeof(flag));
    dis[st][0] = 0;cnt[st][0] = 1;
        int  j, mark, k, minn;
        for (int i = 1;i < 2 * n;i++)
        {
            minn = inf;
            for (j = 1;j <= n;j++)
            {
                if (!flag[j][0] && minn > dis[j][0])
                {
                    k = 0;mark = j;minn = dis[j][0];
                }
                else if (!flag[j][1] && minn > dis[j][1])
                {
                    k = 1;mark = j;minn = dis[j][1];
                }
            }
            if (minn == inf) break;
            flag[mark][k] = true;
            for (j =head[mark];j!=-1;j=E[j].next)
            {
                int v = E[j].en,d= dis[mark][k]+E[j].len;
                //四种情况
                if (dis[v][0]>d)
                {
                    dis[v][1] = dis[v][0];cnt[v][1] = cnt[v][0];
                    dis[v][0] = d;
                    cnt[v][0] = cnt[mark][k];
                }
                else if (dis[v][0] ==d)
                    cnt[v][0] += cnt[mark][k];
                else if (dis[v][1] > d)
                {
                    dis[v][1] = d;
                    cnt[v][1] = cnt[mark][k];
                }
                else if (dis[v][1] == d)
                    cnt[v][1] += cnt[mark][k];
            }

        }
} 
int main()
{
    int t,st,en;
    cin >> t;
    while (t--)
    {
        init();
        int i, x,y,len;
        cin >> n >> m;
        memset(cnt, 0, sizeof(cnt));
        for (i = 1;i <= m;i++)
        {
            cin>>x>>y>>len;
            add(x,y,len);
        }
        cin >> st >> en;
        dij(st,en);
        ans=cnt[en][0];
        if(dis[en][0]+1==dis[en][1])
        ans+=cnt[en][1];
        cout << ans << endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值