hdu 5724(博弈论+状态压缩)

Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1044    Accepted Submission(s): 451


Problem Description
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.
 

Input
Multiple test cases.

The first line contains an integer  T(T100) , indicates the number of test cases.

For each test case, the first line contains a single integer  n(n1000) , the number of lines of chessboard.

Then  n  lines, the first integer of ith line is  m(m20) , indicates the number of chesses on the ith line of the chessboard. Then m integers  pj(1pj20)  followed, the position of each chess.
 

Output
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.
 

Sample Input
  
  
2 1 2 19 20 2 1 19 1 18
 

Sample Output
  
  
NO YES
 

Author
HIT
 
之前没学过博弈论,所以参照别人的代码改的。尽管还有些不太懂,但多做一些题应该就能理解了吧
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=(1<<20)+5;
int sg[maxn];
int SG(int state)
{
    if(sg[state]!=-1)
        return sg[state];
    bool vis[22];
    memset(vis,false,sizeof(vis));
    for(int i=0;i<20;i++)
    {
        if(!(state&(1<<i))) continue;
        for(int j=i+1;j<20;j++)
        {
            if(state&(1<<j)) continue;
            vis[SG(state^(1<<i)^(1<<j))]=true;
            break;
        }
    }
    for(int i=0;i<22;i++)
    {
        if(!vis[i])
        {
            sg[state]=i;break;
        }
    }
    return sg[state];
}
int main()
{
    memset(sg,-1,sizeof(sg));
    for(int i=0;i<(1<<20);i++)
        SG(i);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int ans=0;
        for(int i=0;i<n;i++)
        {
            int m,tmp=0,tmp1;
            scanf("%d",&m);
            for(int j=0;j<m;j++)
            {
                scanf("%d",&tmp1);
                tmp |= (1<<(tmp1-1));
            }
            ans^=sg[tmp];
        }
        if(ans==0) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值