pku2244(约瑟夫环)

Eeny Meeny Moo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3041 Accepted: 2105

Description

Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow.
To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany's cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order.
Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected.

Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.

Input

The input will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of cities in the country.
Input is terminated by a value of zero (0) for n.

Output

For each line of the input, print one line containing the integer m fulfilling the requirement specified above.

Sample Input

3
4
5
6
7
8
9
10
11
12
0

Sample Output

2
5
2
4
3
11
2
3
8
16

Source

 
    本题是个约瑟夫环的变种问题。与传统约瑟夫环比,n给出,k未知,求最小的k是最终剩下的为原序列中第二个数。3 <= n < 150n不大可以考虑双重循环,外层循环枚举k,;内层判断是否满足条件。内层开始去掉第1个,转换为传统约瑟夫环问题(n-1)。至于m为什么存在,且能在比较短的时间找到有待研究,同时还请大牛指出。
 
#include<iostream>
using namespace std;

int Joseph(int n)
{
	for(int m=1;;m++)
	{
		int a=0,i=2;
		while(i<=n)
		{
			a=(a+m)%i;
			i++;
		}
		a=(a+1)%(n+1);
		//cout<<"m="<<m<<"   a="<<a<<endl;
		if(a+1==2)return m;
	}
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		if(!n)break;
		printf("%d\n",Joseph(n-1));
	}
	system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值