hdu4355(三分法)

Party All the Time

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2253    Accepted Submission(s): 765


Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers.
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )
 

Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

Sample Input
  
  
1 4 0.6 5 3.9 10 5.1 7 8.4 10
 

Sample Output
  
  
Case #1: 832
 

Author
Enterpaise@UESTC_Goldfinger
 

Source
 

Recommend
zhuyuanchen520
 
本题题意为在坐标轴上有若干个带有权值wi的点xi,要求在坐标轴上找一个点x使∑|xi-x|^3*wi最小。
若点比较少,可以暴力枚举逐一比较;但本题点比较多且是连续的,故不能用此法。可以联想连续函数的最值问题,本题的函数正好是个凹函数,可以用一定的方法求极值;这个方法就是三分法。
枚举+三分法
#include<iostream>
#include<cstdio>
using namespace std;

const double eps=1e-10;
const int MAXN=50000+100;
double x[MAXN],w[MAXN];
int n;

inline double Max(double aa,double bb)
{
	return aa<bb?bb:aa;
}

inline double Three_find(double xx)
{
	double ans=0;
	for(int i=0;i<n;i++)
	{
		if(x[i]>xx)
			ans+=(x[i]-xx)*(x[i]-xx)*(x[i]-xx)*w[i];
		else 
			ans+=(xx-x[i])*(xx-x[i])*(xx-x[i])*w[i];
	}
	return ans;
}

int main()
{
	int cas,i,tag=1;
	cin>>cas;
	while(cas--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%lf%lf",&x[i],&w[i]);

		double tmp,mid,midmid,low=x[0],high=x[n-1];
		while(low+eps<=high)
		{
			mid=(low+high)/2;
			midmid=(mid+high)/2;
			if(Three_find(mid)+eps>=Three_find(midmid))
				low=mid;
			else high=midmid;
		}
		printf("Case #%d: %d\n",tag++,(int)(Three_find(high)+0.5));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值