Can you answer these queries? - HDU 4027 - 线段树

140 篇文章 0 订阅

Can you answer these queries? - HDU 4027 - 线段树

题目:

  A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.

  You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

  Notice that the square root operation should be rounded down to integer.

Input

  The input contains several test cases, terminated by EOF.

  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)

  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.

  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)

  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output

  For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

  题意:给你n个数,然后给你m个询问,每个询问包含三个整数c a b,c为0代表把区间[a,b]上的每个数都开一次根号,c为1代表输出区间[a,b]的和。

  思路:不能直接用线段树暴力,在这里采用一个bool型数组book,记录这个区间的数是不是全部为1,如果全为1的话在更新的过程中就可以减少很多运算量。我在AC之后又把book数组去掉交了一发,不出所料,Time Limit Exceeded

AC代码:

//
//  main.cpp
//  L
//
//  Created by LucienShui on 2017/5/28.
//  Copyright © 2017年 LucienShui. All rights reserved.
//

#include <iostream>
#include <algorithm>
#include <set>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <iomanip>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cctype>
#define memset(a,b) memset(a,b,sizeof(a))
#define il inline
#define ll long long
#define ull unsigned long long

using namespace std;

#define ls (u<<1)
#define rs (u<<1|1)
#define lson u<<1,l,mid
#define rson u<<1|1,mid+1,r

const int maxn = 100000+7;
ull node[maxn<<2],ans;
bool book[maxn<<2];

void pushup(int u) {
    node[u] = node[ls] + node[rs];
    book[u] = book[ls] && book[rs];
}

void build(int u, int l, int r) {
    if(l==r) {
        scanf("%llu",node+u);
        return ;
    }
    int mid = (l+r)>>1;
    build(lson);
    build(rson);
    pushup(u);
}

void update(int u, int l, int r, int b, int e) {
    if(l==r) {
        node[u] = (ull)sqrt(node[u]);
        if(node[u]<=1) book[u] = true;
        return ;
    }
    int mid = (l+r)>>1;
    if(b<=mid && !book[ls]) update(lson,b,e);
    if(e >mid && !book[rs]) update(rson,b,e);
    pushup(u);
}

void query(int u, int l, int r, int b, int e) {
    if(b <= l && r <= e) {
        ans += node[u];
        return ;
    }
    int mid = (l+r)>>1;
    if(b<=mid) query(lson,b,e);
    if(e >mid) query(rson,b,e);
}

int main ()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    int n,m,cnt{};
    while(~scanf("%d",&n)) {
        printf("Case #%d:\n",++cnt);
        build(1,1,n);
        memset(book,false);
        scanf("%d",&m);
        for(int i=0,c,a,b ; i<m ; i++) {
            scanf("%d%d%d",&c,&a,&b);
            if(a>b) swap(a,b);
            if(c) {
                ans = 0;
                query(1,1,n,a,b);
                printf("%llu\n",ans);
            }
            else update(1,1,n,a,b);
        }
        putchar('\n');
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值