线段树 - Can you answer these queries? - HDU - 4027

Problem Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

题目大意:按顺序给出一些数,两种输入,一种需要输出范围内的总和,另一种时使范围内的每一个数开平方根。

思路:线段树查询与建立都是模板,数据改变和建树相似,还有一点需要优化(数据改变时,若范围内都为1即tree[id]==end-start+1时需要返回),否则会超时。

完整代码如下

#include<math.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define ll long long
const ll N=1e7;
ll tree[N],arr[N],n,o;
void build(ll id,ll start,ll end)
{
	if(start==end) tree[id]=arr[end];
	else
	{
		ll mid=(start+end)/2;
		build(id*2,start,mid);
		build(id*2+1,mid+1,end);
		tree[id]=tree[id*2]+tree[id*2+1];
	}
}
ll query(ll id,ll start,ll end,ll l,ll r)
{
	ll ans=0,mid=(start+end)/2;
	if(r<start||end<l) return 0;
	if(l<=start&&end<=r) return tree[id];
	if(l<=mid) ans+=query(id*2,start,mid,l,r);
	if(mid<r) ans+=query(id*2+1,mid+1,end,l,r);
	return ans;
}
void updata(ll id,ll start,ll end,ll l,int r)
{
	if(tree[id]==end-start+1) return ;
	//当区间内全为1时不需要平方根 
	if(start==end)
	{
		tree[id]=sqrt(tree[id]);
		return ;
	}
	else
	{
		ll mid=(start+end)/2;
		if(l<=mid) updata(id*2,start,mid,l,r);
		if(mid<r) updata(id*2+1,mid+1,end,l,r);
		tree[id]=tree[id*2]+tree[id*2+1];
	}
}
int main()
{
	while(~scanf("%lld",&n))
	{
		int i,k,l,r,m;
		for(i=1; i<=n; i++)
			scanf("%lld",&arr[i]);
		build(1,1,n);
		scanf("%d",&m);
		printf("Case #%lld:\n",++o);
		while(m--)
		{
			scanf("%d %d %d",&k,&l,&r);
			if(l>r) swap(l,r);
			if(k==1)
			{
				ll ans=query(1,1,n,l,r);
				printf("%lld\n",ans);
			}
			else updata(1,1,n,l,r);
		}
		printf("\n");
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值