POJ 2886 Who Gets the Most Candies?(线段树+反素数)

38 篇文章 0 订阅
17 篇文章 0 订阅

这个反素数不太会,这道题目其实也不是自己想出来的看了别人的博客:http://blog.csdn.net/weiguang_123/article/details/7880875

里面说的很详细,我就不在多说了啊。

Who Gets the Most Candies?
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 8786 Accepted: 2675
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers  N (0 <  N  ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898

const int maxn = 5000000;
using namespace std;

struct node
{
    int sum;
    int l, r;
} f[maxn*4];

char name[maxn][20];
int vis[maxn];

int RPrime[]=
{
    1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,
    20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,
    554400
};  //反素数

int fact[]=
{
    1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,
    144,160,168,180,192,200,216
};  //反素数约数个数

void Bulid(int l, int r, int site)
{
    f[site].l = l;
    f[site].r = r;
    f[site].sum = r-l+1;
    if(l == r)
        return ;
    int mid = (l+r)>>1;
    Bulid(l, mid, site<<1);
    Bulid(mid+1, r, site<<1|1);
}

int Search(int site, int num)
{
    f[site].sum--;
    if(f[site].l == f[site].r)
        return f[site].l;
    if(f[site<<1].sum >= num)
        return Search(site<<1, num);
    else
        return Search(site<<1|1, num-f[site<<1].sum);
}

int main()
{
    int n, k;
    while(scanf("%d %d",&n, &k) != EOF)
    {
        Bulid(1, n, 1);
        int p;
        int _max = 0;
        for(int i = 1; i <= n; i++)
            scanf("%s %d",name[i], &vis[i]);
        int i = 0;
        while(1)
        {
            if(RPrime[i] > n)
            {
                p = RPrime[i-1];
                _max = fact[i-1];
                break;
            }
            i++;
        }
        int t;
        for(i = 0; i < p; i++)
        {
            n--;
            t = Search(1,k);
            if(!n)
                break;
            if(vis[t] > 0)
                k=(k-1+vis[t]-1)%n+1;
            else
                k=((k-1+vis[t])%n+n)%n+1;
        }
        cout<<name[t]<<" "<<_max<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值