HDU - 1016 Prime Ring Problem (深搜)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016点击打开链接


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52323    Accepted Submission(s): 23157


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source

基础深搜
线性筛
#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int prime[44];
int a[22];
int book[22];
int n=0;
void getprime()
{
    for(int i=2;i<20;i++)
    {
        if(prime[i]==0)
            for(int j=i+i;j<40;j+=i)
            prime[j]=1;
    }
    prime[1]=1;
}
void dfs(int temp)
{
    if(temp==n)
    {
        if(!prime[a[temp-1]+1])
        {
            for(int i=0;i<n-1;i++)
                printf("%d ",a[i]);
            printf("%d",a[n-1]);
            printf("\n");
        }
        return ;
    }
    for(int i=2;i<=n;i++)
        if(!book[i]&&!prime[a[temp-1]+i])
        {
            a[temp]=i;
            book[i]=1;
            dfs(temp+1);
            book[i]=0;
        }

}
int main()
{
    getprime();
    int step=1;
    while(cin >> n)
    {
        memset(book,0,sizeof(book));
        printf("Case %d:\n",step++);
        a[0]=1;
        dfs(1);
        printf("\n");
    }

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值