A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
#include<stdio.h>
int a[12]={3,5,7,11,13,17,19,23,29,31,34,37};
int b[20],c[20];
int plan(int x)
{
int i;
for(i=0;i<12;i++)
if(a[i]==x)
return 1;
return 0;
}
void plan0(int x,int n)
{
int i;
if(x==n)
{
if(plan(b[0]+b[n-1]))
{
for(i=0;i<n-1;i++)
printf("%d ",b[i]);
printf("%d\n",b[i]);
}
return;
}
for(i=0;i<n;i++)
{
if(c[i]==0&&plan(i+1+b[x-1]))
{
b[x]=i+1,c[i]=1;
plan0(x+1,n);
b[x]=0,c[i]=0;
}
}
return;
}
int main()
{
int n,i=1,j;
while(scanf("%d",&n)!=EOF)
{
for(j=0;j<20;j++)
b[j]=0,c[j]=0;
printf("Case %d:\n",i);
i++;
b[0]=1,c[0]=1;
plan0(1,n);
b[0]=0,c[0]=0;
printf("\n");
}
return 0;
}