PAT A 1048.Student List for Course (25)

题目

Eva loves to collect coins from all over the universe, including someother planets like Mars. One day she visited a universal shopping mall whichcould accept all kinds of coins as payments. However, there was a specialrequirement of the payment: for each bill, she could only use exactly two coinsto pay the exact amount. Since she has as many as 105 coins withher, she definitely needs your help. You are supposed to tell her, for anygiven amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains2 positive numbers: N (<=105, the total number of coins) andM(<=103, the amount of money Eva has to pay). The second linecontains N face values of the coins, which are all positive numbers no morethan 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1and V2 (separated by a space) such that V1 + V2= M and V1 <= V2. If such a solution is not unique,output the one with the smallest V1. If there is no solution, output"No Solution" instead.

Sample Input 1:

8 15

1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14

1 8 7 2 4 11 15

Sample Output 2:

No Solution

 

记录各个价格的货币出现的数量,依次查找1~m/2,m-v是否存在(注意v=m-v的情况)

 

代码:

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
	int n,m;
	cin>>n>>m;
	int coin[1001]={0};	//记录各个价值的硬币数量,需要适配价值,故需要2倍

	int value;
	int i,j;
	for(i=0;i<n;i++)	//输入数据
	{
		scanf("%d",&value);
		coin[value]++;
	}

	for(i=1;i<=m/2;i++)	//扫描范围
	{
		if(coin[i]>=1&&coin[m-i]>=1&&i!=m-i)	//i!=m-i
		{
			cout<<i<<" "<<m-i;
			return 0;
		}
		if(coin[i]>=2&&i==m-i)	//i==m-i
		{
			cout<<i<<" "<<m-i;
			return 0;
		}
	}

	cout<<"No Solution";

	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值