PAT A 1009. Product of Polynomials (25)

原题

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively.  It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.  

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input.  Notice that there must be NO extra space at the end of each line.  Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

 

求两个多项式的乘积,直接模拟。

跳过无效项即可,题目没说清,四舍五入后为0.0的项不显示。

 

 

代码:

#include <iostream>
using namespace std;

int main()
{
	int k1,k2,k=0;		//多项式1、2、乘积有效项
	double poly1[1001];	//多项式1,标号对应次数
	double poly2[1001];	//多项式2
	double poly[2001];	//乘积
	
	int i,j,exp;
	double coe;
	for(i=0;i<1001;i++)	//初始化
	{
		poly1[i]=0.0;
		poly2[i]=0.0;
	}
	for(i=0;i<2001;i++)
		poly[i]=0.0;
	
	cin>>k1;
	for(i=0;i<k1;i++)	//输入
	{
		cin>>exp>>coe;
		poly1[exp]=coe;
	}
	cin>>k2;
	for(i=0;i<k2;i++)
	{
		cin>>exp>>coe;
		poly2[exp]=coe;
	}
	for(i=0;i<1001;i++)	//相乘
		for(j=0;j<1001;j++)
			poly[i+j]+=poly1[i]*poly2[j];

	i=2000;
	while(i>=0&&poly[i]<0.05&&poly[i]>-0.05)
		i--;
	if(i<0)
		cout<<0;
	else
	{
		j=i;
		while(j>=0)	//统计有效项
		{
			if(poly[j]>=0.05||poly[j]<=-0.05)
				k++;
			j--;
		}
		cout<<k;
		cout<<fixed;
		cout.precision(1);
		while(i>=0)	//输出
		{
			if(poly[i]>=0.05||poly[i]<=-0.05)
				cout<<" "<<i<<" "<<poly[i];
			i--;
		}
	}

	return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值