HDU 2612 Find a way(BFS)

Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#



Sample Output
66
88

66

题意:Y和M要在KFC约会,地图上有多个KFC,求在哪个KFC两人所走总距离最短,(注意KFC可以当做路)

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
#define INF 0x3fffffff
char map[201][202];
int vis[202][102];
int dis[202][202][2];
int f[4][2]= {0,1,1,0,-1,0,0,-1};
int n,m,flag;
struct node
{
    int x,y,step;
} pose;
void bfs()
{
    queue<node>Q;
    node q,p;
    vis[pose.x][pose.y]=1;
    Q.push(pose);
    while(!Q.empty())
    {
        q=Q.front();
        Q.pop();
        for(int i=0; i<4; i++)
        {
            p=q;
            p.x+=f[i][0];
            p.y+=f[i][1];

            if(p.x>=0&&p.y>=0&&p.x<n&&p.y<m&&map[p.x][p.y]!='#'&&!vis[p.x][p.y])
            {
                vis[p.x][p.y]=1;
                p.step+=11;
                if(map[p.x][p.y]=='@')
                    dis[p.x][p.y][flag]=p.step;
                Q.push(p);
            }
        }
    }
}
int main()
{
    int i,j;
    while(cin>>n>>m)
    {
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
                dis[i][j][0]=dis[i][j][1]=INF;
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
                cin>>map[i][j];
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
            {
                if(map[i][j]=='Y')
                {
                    pose.x=i;
                    pose.y=j;
                    pose.step=0;
                    flag=0;
                    memset(vis,0,sizeof(vis));
                    bfs();
                }
                else if(map[i][j]=='M')
                {
                    pose.x=i;
                    pose.y=j;
                    pose.step=0;
                    flag=1;
                    memset(vis,0,sizeof(vis));
                    bfs();
                }
            }
        int minn=INF;
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
                if(map[i][j]=='@'&& minn>dis[i][j][0]+dis[i][j][1])
                    minn=dis[i][j][0]+dis[i][j][1];
        cout<<minn<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值