杭电 HDU ACM 2612 Find a way (简单两路广搜)

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6362    Accepted Submission(s): 2116


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88 66
 

Author
yifenfei


有一点需要说明 dis开了个三维数组 第三维表示不同的两次搜索,每次给第三维传递一个参数来表示哪一次。另外对于dis初始化的时候应初始化无穷大,因为有可能某个KFC
根本就无法到达,影响最后求结果。
说说题外话:留校不回家真是够人…… 训练效果也突出不出来……
#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=204;
const int M=0x1f1f1f1f;
int n,m,z;
char cnt[INF][INF];
int dir[][2]= {{1,0},{0,-1},{-1,0},{0,1}};
int dis[INF][INF][2];
int vis[INF][INF];
struct Node
{
    int x,y,step;
    Node(int x,int y,int z):x(x),y(y),step(z) {}
    Node() {}
};
void bfs(int x,int y)
{
    memset(vis,0,sizeof(vis));
    vis[x][y]=1;
    queue<Node>q;
    q.push(Node(x,y,0));
    while(!q.empty())
    {
        Node u=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            int tx=u.x+dir[i][0];
            int ty=u.y+dir[i][1];
            if(!vis[tx][ty]&& tx>=1&&tx<=n&&ty>=1&&ty<=m&&cnt[tx][ty]!='#')
            {
                vis[tx][ty]=1;
                dis[tx][ty][z]=u.step+1;
                q.push(Node(tx,ty,u.step+1));
            }
        }

    }
}

int main()
{
    while(cin>>n>>m)
    {
        for(int i=0;i<2;i++)
            for(int j=1;j<=n;j++)
            for(int k=1;k<=m;k++)
            dis[j][k][i]=M;
        for(int i=1; i<=n; i++)
            scanf("%s",cnt[i]+1);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
            {
                if(cnt[i][j]=='Y')
                {
                    z=1;
                    bfs(i,j);
                }
                if(cnt[i][j]=='M')
                {
                    z=0;
                    bfs(i,j);
                }

            }

        int ans=M;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if(cnt[i][j]=='@')
                   {
                        ans=min(ans,dis[i][j][0]+dis[i][j][1]);
                      
                   }
            }
        }
        cout<<ans*11<<endl;
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值